Closed Bug 1423090 Opened 4 years ago Closed 4 years ago

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected

People

(Reporter: jan, Assigned: mtseng)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community, regression, Whiteboard: [wr-mvp])

Attachments

(1 file)

Spinoff from bug 1422835 comment 1. (Feel free to edit the bug title.)

Nightly 59 x64 20171204234137 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: layers.acceleration.force-enabled, gfx.webrender.enabled, gfx.webrender.blob-images, image.mem.shared

https://codepen.io/YusukeNakaya/pen/ZXmJjj

mozregression --good 2017-11-01 --bad 2017-12-04 --pref "layers.acceleration.force-enabled:true" "gfx.webrender.enabled:true" "gfx.webrender.blob-images:true" "image.mem.shared:true"
> 13:09.10 INFO: Last good revision: ef9858e9ad38718eea180a62bb5b65561ad57d91
> 13:09.10 INFO: First bad revision: cdf4bb1c6af6e53643d2beb0f10a2ce29207ff5e
> 13:09.10 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ef9858e9ad38718eea180a62bb5b65561ad57d91&tochange=cdf4bb1c6af6e53643d2beb0f10a2ce29207ff5e

> cdf4bb1c6af6	Kartikaya Gupta — Bug 1417062 - Update for API change in WR PR 2043. r=nical
> 72cfd88fe0a0	Kartikaya Gupta — Bug 1417062 - Update reftest annotations for changes in WR PR 2031. r=nical
> c80c224d6b0c	Kartikaya Gupta — Bug 1417062 - Update webrender to commit d490a74c438d987122c600afca6bb2247ab38637. r=nical
Has Regression Range: --- → yes
Whiteboard: [wr-mvp] [triage] → [wr-reserve]
It looks like the problem is that the two filters are applied in reverse order, which should be fixed by https://github.com/servo/webrender/pull/2150 which in turn should be applied by https://bugzilla.mozilla.org/show_bug.cgi?id=1422317
Depends on: 1422317
This is fixed in today's nightly as expected.
Assignee: nobody → mtseng
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Verified fixed in Nightly 59 x64 20171206100053 de_DE @ Debian Testing (KDE, Radeon RX480). Thank you!
Status: RESOLVED → VERIFIED
Priority: P2 → P1
Whiteboard: [wr-reserve] → [wr-mvp]
You need to log in before you can comment on or make changes to this bug.