Closed Bug 1422317 Opened 2 years ago Closed 2 years ago

Update webrender to b7714b1d4348c00682b5643ea0e3f0b15adaeda5

Categories

(Core :: Graphics: WebRender, enhancement, P1)

59 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1421275 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Blocks: 1421041
R7 regression range:

*   5e6494c0 Auto merge of #2150 - mephisto41:chain-filter, r=glennw
|\
| * c378cf9a Reverse apply filters.
*   c966fdba Auto merge of #2147 - kvark:pbo-style, r=glennw
|\
| * 61f59d8a UploadMethod configuration
| * e2d18711 TextureUploader abstraction
*   d1feb4f5 Auto merge of #2146 - glennw:b10, r=kvark
|\
| * b562ddf6 Convert rectangle from prim to brush shader and support segments.
* 7d55afc0 Auto merge of #2155 - lsalzman:mac-bold, r=glennw
* f56f9b2d fake bold for Mac font backend

So that's almost certainly from servo/webrender#2150. In fact it was noted at https://github.com/servo/webrender/pull/2150#issuecomment-348868389
Blocks: 1394570
Blocks: 1423062
Blocks: 1420956
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> Linux green, one of the windows debug jobs is red although I'm not sure why.
> I don't see anything in the log that looks abnormal - no crashes or panics.

Oh, this is probably because of this:

04:30:36     INFO - 
04:30:36     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
04:30:36     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
04:30:36     INFO -    0 |TOTAL                                 |       58    31680| 7967154      198|
04:30:36     INFO -   99 |RenderDXGIYCbCrTextureHostOGL         |      160    31680|     198      198|
04:30:36     INFO - 
04:30:36     INFO - nsTraceRefcnt::DumpStatistics: 180 entries
04:30:36     INFO - TEST-INFO | leakcheck | gpu process: leaked 198 RenderDXGIYCbCrTextureHostOGL
04:30:36    ERROR - TEST-UNEXPECTED-FAIL | leakcheck | gpu process: 31680 bytes leaked (RenderDXGIYCbCrTextureHostOGL)

I'll file another bug for it but it shouldn't block landing the update.
Alias: wr-future-update
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Priority: P2 → P1
Summary: Future webrender update bug → Update webrender to 439dfeff4fa04a3c3afc6ecd8f83c2bd303c9a7c
Version: unspecified → 59 Branch
Comment on attachment 8934544 [details]
Bug 1422317 - Update webrender to commit b7714b1d4348c00682b5643ea0e3f0b15adaeda5.

https://reviewboard.mozilla.org/r/205452/#review211048
Attachment #8934544 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8934545 [details]
Bug 1422317 - Update Cargo lockfiles and re-vendor rust dependencies.

https://reviewboard.mozilla.org/r/205454/#review211052
Attachment #8934545 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8934546 [details]
Bug 1422317 - Update reftest results from changes in WR PR 2150.

https://reviewboard.mozilla.org/r/205456/#review211056
Attachment #8934546 - Flags: review?(jmuizelaar) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 2a6aa312a2e9 -d 91033fe6389a: rebasing 437438:2a6aa312a2e9 "Bug 1422317 - Update webrender to commit 439dfeff4fa04a3c3afc6ecd8f83c2bd303c9a7c. r=jrmuizel"
rebasing 437439:4c7b497a1604 "Bug 1422317 - Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel"
merging third_party/rust/smallvec/.cargo-checksum.json
merging third_party/rust/smallvec/Cargo.toml
merging third_party/rust/smallvec/lib.rs
merging toolkit/library/gtest/rust/Cargo.lock
merging toolkit/library/rust/Cargo.lock
warning: conflicts while merging third_party/rust/smallvec/.cargo-checksum.json! (edit, then use 'hg resolve --mark')
warning: conflicts while merging third_party/rust/smallvec/Cargo.toml! (edit, then use 'hg resolve --mark')
warning: conflicts while merging toolkit/library/gtest/rust/Cargo.lock! (edit, then use 'hg resolve --mark')
warning: conflicts while merging toolkit/library/rust/Cargo.lock! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Since this bounced I'll take the opportunity to update to b7714b1d4348c00682b5643ea0e3f0b15adaeda5 per Lee's request, since it includes servo/webrender#2165 which would be good to have.
Summary: Update webrender to 439dfeff4fa04a3c3afc6ecd8f83c2bd303c9a7c → Update webrender to b7714b1d4348c00682b5643ea0e3f0b15adaeda5
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/52277221fade
Update webrender to commit b7714b1d4348c00682b5643ea0e3f0b15adaeda5. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/483371920adb
Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/9f8cde87eaa7
Update reftest results from changes in WR PR 2150. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/52277221fade
https://hg.mozilla.org/mozilla-central/rev/483371920adb
https://hg.mozilla.org/mozilla-central/rev/9f8cde87eaa7
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Depends on: 1424358
Duplicate of this bug: 1424596
Depends on: 1428570
You need to log in before you can comment on or make changes to this bug.