Closed Bug 142649 Opened 21 years ago Closed 19 years ago

Invalid testcases in DOM JavaScript testsuite: browser is working right, but testcase (may) fails

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED

People

(Reporter: dacut, Assigned: desale)

References

()

Details

Two testcases in the JavaScript suite (accessible via the Debug > Verification >
JavaScript menu, cases are001.html and are008.html) fail in RC1.

These testcases are invalid -- see bugs 41367 and 12559.  The expected result
should be modified to match what Mozilla is returning.

http://mozilla.org/quality/ngdriver/suites/javascript/are001.html
http://mozilla.org/quality/ngdriver/suites/javascript/are008.html
Prashant, could you make sure this gets some attention from whoever is in charge
of these tests?
Assignee: jst → desale
Status: UNCONFIRMED → NEW
Ever confirmed: true
Will cleanup bad JS testcases, soon.
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021016"


From "http://mozilla.org/quality/browser/standards/javascript/tcmatrix/window.html"

I found many testcases not to "work" as expected: here are some examples

*http://mozilla.org/quality/ngdriver/suites/javascript/win002.html
 http://mozilla.org/quality/ngdriver/suites/javascript/win006.html
 http://mozilla.org/quality/ngdriver/suites/javascript/win024.html
 http://mozilla.org/quality/ngdriver/suites/javascript/win035.html
 *Not Found

*http://mozilla.org/quality/ngdriver/suites/javascript/win046.html
 *Read window.frames [object WindowCollection] failed Bug report required
[object Window] [object WindowCollection]

*http://mozilla.org/quality/ngdriver/suites/javascript/win010.html
 http://mozilla.org/quality/ngdriver/suites/javascript/win011.html
 *Fails in new Tab, Succeeds in new Window: Add a warning !

*http://mozilla.org/quality/ngdriver/suites/javascript/win040.html
 *Add a warning for window resize !

*http://mozilla.org/quality/ngdriver/suites/javascript/win041.html
 *Read window.screenY 0 failed Bug# 5998 28 0

I stopped testing at win54.


Then, I checked the initial report:

*http://mozilla.org/quality/ngdriver/suites/javascript/are001.html
 *Read Area.hash [1st Area] #angels failed Bug# 12543 #angels?ser=15 #angels
Read Area.hash [2nd Area] #angels1 failed Bug# 12543 #angels1?ser=12 #angels1
Read Area.hash [3rd Area] #angels2 failed Bug# 12543 #angels2?ser=14 #angels2

*http://mozilla.org/quality/ngdriver/suites/javascript/are008.html
 Read Area.search [1st Area] ?ser=15 failed Bug# 12559  ?ser=15
Read Area.search [2nd Area] ?ser=12 failed Bug# 12559 ?ser=12
Read Area.search [3rd Area] ?ser=14 failed Bug# 12559 ?ser=14

It's too bad to have testcases which look messed up :-(
http://mozilla.org/quality/ngdriver/suites/javascript/nav002.html should be
removed or modified - it's a wontfix: bug 61071
Depends on: 194799
Summary: Invalid testcases in JavaScript testcases → Invalid testcases in DOM JavaScript testsuite
*** Bug 201668 has been marked as a duplicate of this bug. ***
Depends on: 119955
Added bug 135793 to dependency-list. Hmm, there's an administrative problem
here: There are bugs dealing with false results from testcases that are
resolved, ie marked INVALID, because the testcases are invalid. Should they be
reopened and added to the dependency-list?
Depends on: 135793
Re comment 7:

You can make bugs dependent whatever their current status is;
if they are already resolved, it will serve as history (only).

(Re-opening bugs is a different story; and it is not needed to make them dependent.)
(Due to its current Summary, this bug has become sort of a "meta-bug":
Feel free to comment if this should be dealt with in a more appropriate way.)
Depends on: 203158
Depends on: 142477, 185312, 185313
Depends on: 146788
Depends on: 142774
Depends on: 53782
Depends on: 144002
Depends on: 47280
Depends on: 138402
Summary: Invalid testcases in DOM JavaScript testsuite → Invalid testcases in DOM JavaScript testsuite: browser is working right, but testcase (may) fails
*** Bug 217901 has been marked as a duplicate of this bug. ***
*** Bug 218683 has been marked as a duplicate of this bug. ***
Depends on: 215297
No longer depends on: 146788
I fixed all the dependencies of this bug (apart from bug 203158 which was
morphed). Can we mark this fixed?
No longer depends on: 203158
Depends on: 226772
Depends on: 226774
Thank you Fabian! Marking FIXED. Reopen if there's more to do here...
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.