Closed Bug 1425171 Opened 3 years ago Closed 2 years ago

about:addons should indicate when an extension is a study

Categories

(Toolkit :: Add-ons Manager, defect, P5)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox59 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: imyxhuang, Unassigned)

References

Details

(Keywords: nightly-community)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171209103238

Steps to reproduce:

Enable studies, go to about:addons.


Actual results:

about:addons currently shows a very sketchy extension. Mine has the title "looking glass," and the only description is "MY REALITY IS JUST DIFFERENT THAN YOURS" People are pretty scared. If I didn't search up the extension and find a reddit page about this, I wouldn't have known that this wasn't malware.


Expected results:

To prevent this in the future, I think studies really need to be shown seperately from regular extensions. Just merging about:studies as one of the side tabs in about:addons and not showing the studies in about:addons would fix it, or even just making a small icon or something that's shown to users on about:addons indicating it's a study.
As a side note, whoever is approving these opt-out studies really needs to make sure that the descriptions are helpful. . . .
Related to Bug 1424977
(In reply to Mark from comment #1)
> Related to Bug 1424977

Yep. I wanted to create a separate bug for the request of this feature, though. The looking glass extension is just an example of why I think this is necessary.
Component: Untriaged → Shield Study
Product: Firefox → Shield
Version: Trunk → unspecified
There was once the "Experiments" tab, like "Extensions" etc. in about:addons/Add-ons Manager, no idea why this was changed and removed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Component: Shield Study → Add-ons Manager
Product: Shield → Toolkit
Because of repeated off-topic comments on related bugs, I'm closing comments to people outside the editbugs group. 

Off-topic comments are noise in the bug and people's email, and don't bring a bug to resolution.

Remember that your use of Bugzilla is subject to https://bugzilla.mozilla.org/page.cgi?id=etiquette.html.
Restrict Comments: true
See Also: → 1425819
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #3)
> There was once the "Experiments" tab, like "Extensions" etc. in
> about:addons/Add-ons Manager, no idea why this was changed and removed.

Shield studies are delivered in a different way that the old experiments were.  about:studies has replaced the Experiments tab in the addons manager, you can find information about current and past Shield studies there.
Priority: -- → P5
(In reply to Andrew Swan [:aswan] from comment #5)
> (In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see
> your comment/reply/question/etc.) from comment #3)
> > There was once the "Experiments" tab, like "Extensions" etc. in
> > about:addons/Add-ons Manager, no idea why this was changed and removed.
> 
> Shield studies are delivered in a different way that the old experiments
> were.  about:studies has replaced the Experiments tab in the addons manager,
> you can find information about current and past Shield studies there.

Could be.

But the point was that this study/experiment was still seen as "Looking Glass 1.0.3" extension with ""My reality is different than yours" description in about:addons/Add-ons Manager.
In about:studies it was seen as "pug-experience" with "My reality is different than yours" description.
Was it intended?

What's more about:studies are not discoverable in GUI.
Flags: needinfo?(aswan)
I agree that about:studies should be more discoverable.  Please file a separate bug for that in the "Shield" product.
I'm not sure what the intention is about showing the title/description in about:studies, that's a question for the Shield maintainers.
Flags: needinfo?(aswan)
All extensions in the about:addons Extensions list require user consent to be installed/enabled, whether directly or side-loaded, except for studies. Studies appear without warning and without being easily distinguished which breaks the Principle of Least Surprise and will continue to cause confusion in the future if not addressed.


(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #6)
> What's more about:studies are not discoverable in GUI.

about:studies is discoverable in about:preferences but a link in about:addons would be more convenient.
Given that bug 1365349 indicates that the plan going forward is to hide studies from about:addons entirely, and rely on about:studies for study management, do we still want this bug?
Nope, thanks for the reminder
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.