Last Comment Bug 143085 - RFE: View-->Messages-->Flagged menu option desired
: RFE: View-->Messages-->Flagged menu option desired
Status: RESOLVED WORKSFORME
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 All
-- enhancement with 24 votes (vote)
: ---
Assigned To: mail
: laurel
:
Mentors:
: 122928 184172 192731 225176 227944 (view as bug list)
Depends on: 201433
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-08 12:26 PDT by Steve VanSlyck
Modified: 2006-06-12 07:04 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Steve VanSlyck 2002-05-08 12:26:04 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

I would like to see Flagged as one of the options under View Messages. Kind of
an additional method of watching.

Reproducible: Always
Steps to Reproduce: Not applicable.

Actual Results:  Not applicable.

Expected Results:  Not applicable.
Comment 1 User image Steve VanSlyck 2002-06-05 10:03:30 PDT
Be nice to be able to sort newsgroup messages by attachment, too.
Comment 2 User image laurel 2002-06-05 10:18:02 PDT
I think there may already be a request logged about this.
Comment 3 User image Boris 'pi' Piwinger 2002-08-12 08:24:59 PDT
*** Bug 122928 has been marked as a duplicate of this bug. ***
Comment 4 User image Mike Cowperthwaite 2003-06-19 10:15:06 PDT
*** Bug 184172 has been marked as a duplicate of this bug. ***
Comment 5 User image Mike Cowperthwaite 2003-06-19 10:16:02 PDT
See also bug 192731.
Comment 6 User image Brett Taylor 2003-07-13 18:48:03 PDT
Still here in 1.4 Final.  Please fix, would be most useful.
Comment 7 User image Matthijs Wensveen 2003-08-19 22:57:19 PDT
I agree. The view pulldown/menu can be used to select almost every aspect of a
message (even message headers), but NOT message flags.
Maybe not necessary to put it in the menu directly, but it would be very useful
to be able to have "Flag Status" in the customize dropdown.
Comment 8 User image Mike Cowperthwaite 2003-08-20 08:10:10 PDT
*** Bug 192731 has been marked as a duplicate of this bug. ***
Comment 9 User image Malte Rücker (mbr) 2003-12-09 11:29:09 PST
*** Bug 227944 has been marked as a duplicate of this bug. ***
Comment 10 User image Asa Dotzler [:asa] 2004-02-02 18:53:47 PST
*** Bug 225176 has been marked as a duplicate of this bug. ***
Comment 11 User image Gert-Jan Vons 2004-09-02 06:34:48 PDT
Any news on this topic? After switching to thunderbird I started using the
message flag to signal mails that require further actions, but since viewing
them is difficult without having "Flag status" in "view->Customize" it is a bit
of a pain...

By the way, bug #234222 seems to be a dupe of this one.
Comment 12 User image Ben 2004-09-02 06:43:51 PDT
I recently learned that you can simply label the messages with the keys 1, 2, 3,
4, 5 and 0 and labeled messages can easily be filtered in the view. Maybe you
could use this as a work-around.
Comment 13 User image Shoshannah Forbes 2004-09-03 09:50:13 PDT
(In reply to comment #12)
> I recently learned that you can simply label the messages with the keys 1, 2, 3,
> 4, 5 and 0 and labeled messages can easily be filtered in the view. Maybe you
> could use this as a work-around.

They don't work across email clients when using an IMAP account, while flag
does. So if you have an imap account and check your email with multiple clients,
you don't have a workaround- it either works with TB or with the other clients,
but not with both :-(
Comment 14 User image Shoshannah Forbes 2004-09-25 13:30:36 PDT
is bug #234222 a dup of this bug?
Comment 15 User image Mike Cowperthwaite 2004-09-25 16:28:56 PDT
Not a dupe because that's a TB bug, this is a MailNews bug.  Front-end bugs and 
RFE's should be considered separate between the two products.
Comment 16 User image Zer0halo 2004-10-06 10:20:35 PDT
Any chance of this being fixed/added? Would make the "flag" much more useful.
Thanks.
Comment 17 User image bugzilla 2006-06-11 12:19:00 PDT
This option should be made available since the /flagged attribute is part of the IMAP RFC 3501. Ref. http://www.faqs.org/rfcs/rfc3501.html Section 2.3.2

I'm not hopeful... I see the last comment here is well over a year ago... :-(

Following the RFCs is a good way to make a good product that will work with most other components. To make it better, means is will also include the "should" parts of an RFC as well.
Comment 18 User image Matthijs Wensveen 2006-06-12 00:36:16 PDT
Flagging itself is already implemented. You can even sort on it when you display the flagged column. It just that you might to only display the flagged items using the "View:" dropdown or the "View-->Messages" menu.

Since there are so many ways to work around this problem (sorting on it, or using labels), this probably won't ever get fixed.
Comment 19 User image mark krischer 2006-06-12 00:44:22 PDT
(In reply to comment #18)
> Flagging itself is already implemented. You can even sort on it when you
> display the flagged column. It just that you might to only display the flagged
> items using the "View:" dropdown or the "View-->Messages" menu.
> 
> Since there are so many ways to work around this problem (sorting on it, or
> using labels), this probably won't ever get fixed.
> 

as people keep mentioning, flags are common across IMAP clients.  so the work arounds are insuffient.
Comment 20 User image Mike Cowperthwaite 2006-06-12 07:04:57 PDT
This feature has been available since the fix for bug 272709 went in (available in TB 1.5 and Seamonkey 1.0).  You have to create the view yourself, but using the criterion   Status, Is, Flagged   will give the desired results.

Note that an additional fix has recently gone in (bug 278263) to allow Group-
by-Sort when sorting on flag; this separates the flagged and non-flagged into two collapsable groups, altho those individual groups can't be re-sorted or threaded like a View can.

Note You need to log in before you can comment on or make changes to this bug.