Mozilla seem to hang (over 20min) while importing 2500 favorites at startup

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: ne4k, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    1.0rc2

Installed Mozilla 1.0rc2 from the download page.  Whenever the navigator is
launched, it locks up and remains unresponsive.  I had the same problem with
1.0rc1 but not with 0.98-2002020406.  Mail/newsgroups, addressbook, and composer
do not lock up unless a navigator is launched.

Reproducible: Always
Steps to Reproduce:
1.Install 1.0rc2 on Windows 2000 Server with Service Pack 2.
2.Launch navigator.
3.

Actual Results:  As soon as Navigator is fully open with all menus displayed, it
stops responding and remains unresponsive until killed. 

Expected Results:  Remain usable and responsive.
Reporter: Have you installed Mozilla over an older build ?
if yes : uninstall the old build, delete all files in c:\programs\mozila.org
(but save your plugins first) and reinstall mozilla (you will not loose your
mails, settigs...

If you still get the problem try a new profile:
run "mozilla -profilemanager" and create an additional test profile
(close mozilla first)
Severity: blocker → critical
Keywords: hang
(Reporter)

Comment 2

17 years ago
Okay, I uninstalled 0.9.8 and removed the entire
C:\Program Files\mozilla.org\ directory.  I then
installed 1.0rc2 build 2002051006.  Again the
navigator hangs as soon as it is launched.  I killed
it and ran mozilla -profilemanager and created a
profile called "Test User".  I launched the navigator
with that profile and again it locked up.  

It all looks perfectly normal with all menu items
present as well as the sidebar and
http://www.mozilla.org/ in the address window.  It
simply doesn't respond to any keys or mouseclicks and
it doesn't update it's graphics, so it becomes a blank
window if anything is opened over it.

This is exactly the same problem I had with 1.0rc1 and
seems unique to Windows 2000 Server.  I've run rc1
successfully on Windows 2000 Pro, WinXP, WinME, and
Linux.  I haven't had time to try rc2 on anything
except win2k server.

Comment 3

17 years ago
I have consistently been experiencing the same problems with every version 
since 0.98 (including 1.1 alpha) on Win2k Server SP2.

Have tried the "new profile" suggestion - unsuccessful. And as a matter of 
course I remove all traces of an old version before installing a new one. All 
other modules work fine (Mail, Calendar, IRC, Address Book, Composer)...but 
these can only be opened from a non-Navigator module.

Other platforms where I have had successful installations post-0.98:
* Windows 2000 Professional SP2
* Windows 98 SE
* Mandrake Linux 8.0, 8.1
* Windows NT 4 Workstation SP6

Comment 4

17 years ago
I have just installed 1.1b {Build ID: 2002072104} on Windows 2000 Server SP2. 
My build of Win2K Server SP2 has not changed since my last comment (05.07.2002).
Navigator crashed on startup the first couple of times but then seemed to 
automatically recover from a crash and worked OK. Subsequently, it starts OK.

As this bug had not been closed, I don't know what work has been done in since 
1.1a to rectify this problem, but I would be very interested to know!

This is great news and I am really pleased to have Mozilla back on my desktop 
at last. Well done to those concerned.

NB. I deliberately did not change the status of this bug as I am not 
the "owner" and others may still be experiencing problems.

- Greg.
ROB: Is this is now working with Mozilla 1.1b ?
(Reporter)

Comment 6

16 years ago
Unfortunately, no.  Navigator still hangs as soon as
it launches.  Mail and composer still work fine.  I
tried it with both Service Pack 2 and again with
Service Pack 3 and see no difference.  

Navigator has not worked for me since Mozilla 0.9.8 on
Windows 2000 Server, but I've had no such problems on
any other OS.

Comment 7

16 years ago
Anyone else using win2k server can confirm this bug or indicate worksforme in a
comment would be much appreciated.
Keywords: qawanted
Whiteboard: Win2k SERVER only
we need more informations to fix this bug :-(
(like a stack trace..)
==> default owner
Assignee: matti → asa
QA Contact: imajes-qa → asa
Rob build a debug build to solve this. After genrating a nspr log we found that
Mozilla imports his IE favorites over 20min (2500+ IE favorites) and Mozilla seems 
to hang at the splash screen.
(note Mozilla tries to import even if the IE favorites are currently broken.)

The solution would be a user feedback for Importing..
Assignee: asa → ben
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → Bookmarks
Ever confirmed: true
Keywords: hang, qawanted
QA Contact: asa → claudius
Summary: Navigator locks up on Windows 2000 Server SP2 → Mozilla seem to hang (over 20min) while importing 2500 favorites at startup
Whiteboard: Win2k SERVER only

Updated

16 years ago
Blocks: 120814
(Reporter)

Comment 11

16 years ago
As an addition to this, I should mention that after waiting the 20+ minutes for 
it to import the IE favorites, it didn't.  There's a folder under Bookmarks for 
Imported IE Favorites, but it is quite empty.  Maybe they got stuffed somewhere 
else that I haven't found yet, but they're certainly not in the place I 
expected them to be.  

So, in short, the debug shows navigator processing 2500+ IE Favorites for 20+ 
minutes, but what it ultimately did with them I can only guess.  This is not a 
major problem for me because I didn't actually want to import my IE favorites, 
but if it's an intended feature, it seems quite broken to me.
see bug 84272 (disable import via UI) and bug 176715 (bookmark import is broken)

Comment 13

16 years ago
*** Bug 185404 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Comment 14

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 15

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.