Update webrender to 941bf5ac998061689a1bcd18d417f1f315e41ae6

RESOLVED FIXED in Firefox 61

Status

()

enhancement
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: kats, Assigned: kats)

Tracking

(Blocks 2 bugs)

61 Branch
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

(Whiteboard: [gfx-noted], )

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1447998 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ bba5602b59e6c0a7a911779c5aa42c8ae69e66b9

https://treeherder.mozilla.org/#/jobs?repo=try&revision=c405075b734f1ae4a50d7bfae00e34e5c7449aa0
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f46a5fb40a8dc1fd66e0263f3ce39c5464f3d87c

Bustage. Regression range:

*   bba5602b Auto merge of #2589 - glennw:validate, r=mrobinson
|\
| * e0fcc04f Fix up some shader validations, remove unused shader.
|/
* 190ed69b Auto merge of #2574 - fschutt:make_debug_renderer_optional, r=glennw
* 22771705 Added LazyInitializedDebugRenderer, removed trailing whitespace
* 93563784 Move any code that isn't used by the debug renderer behind a feature flag
* cd44988e Initialize the DebugRenderer lazily
*   2c3ec02d Fix merge conflicts
|\
| * 598601fe Only enable the DebugRenderer and Profiler when feature=debug_renderer is enabled (default to true for wrench)
* 41d64e89 Make DebugRenderer optional to save startup time

So probably from servo/webrender#2574
Only one try push from now onwards since I can enable the windows reftests with a taskcluster config change rather than needing a separate patch to force-enable WR.

WR @ 7bd5ad3fef5b36653ad9d2bd7418c6a22d2f227b

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9a9c28c89fc71f8c6a5ac4f9f6d6b480ffd5b485
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0880ea65aa6a2be77d97e46e5aa21a1adea00b31
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e26901fb6e8ed2108446dd1b50ac66a890d7a7e4
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0b781713b29ca64843f84ea8860786ef48360329
https://treeherder.mozilla.org/#/jobs?repo=try&revision=be9e74b7c7dd60b541bbf193bb8b10001445837d
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7a32a30d3a14ed8af9bc3903b09464e3ee97e91e
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fcc9ab69e5e1d43af20798497d25274a72be5999

Green.

WR @ 93a8d6b2f7d1ff4fcd25c4294ae38d2ab466c917

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4dd6b9f5deda04a969f966b16df76f6acca1b2ce
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bf104885b56f928e61ed8cd24afc011175dfa796

Green

WR @ 3d541ccee469638603ec194da09227c991642c64

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3b33947edef50c7f1cf9ee1d5f087067df57863e

Green

WR @ 7ca4558f247ac02b9a49c0a9bf5d3972c451092f

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e9dc076b65fb82417dfe244c2516913c18f672b0

Green

WR @ 975b41ff64840b9cd1f815c583efc710363def50

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a5285f6f681428f7d96e90aa3b96e80234d7e6cc

Green
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 941bf5ac998061689a1bcd18d417f1f315e41ae6
Version: unspecified → 61 Branch
Comment on attachment 8965034 [details]
Bug 1449562 - Update webrender to commit 941bf5ac998061689a1bcd18d417f1f315e41ae6.

https://reviewboard.mozilla.org/r/233764/#review239410
Attachment #8965034 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8965035 [details]
Bug 1449562 - Update Cargo lockfiles and re-vendor rust dependencies.

https://reviewboard.mozilla.org/r/233766/#review239414
Attachment #8965035 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca8e5e236ab3
Update webrender to commit 941bf5ac998061689a1bcd18d417f1f315e41ae6. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/dfc311c89e45
Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
No longer depends on: 1451478
https://hg.mozilla.org/mozilla-central/rev/ca8e5e236ab3
https://hg.mozilla.org/mozilla-central/rev/dfc311c89e45
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.