Closed Bug 1450520 Opened 3 years ago Closed 3 years ago

flickering of Facebook blue bar

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 blocking verified

People

(Reporter: heycam, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(3 files)

With a newly installed Firefox Nightly (2018-03-31) I'm getting flickering of the Facebook blue bar when mousing around the page.  See the attached video.
Summary: flicking of Facebook blue bar → flickering of Facebook blue bar
Perhaps relatedly, I get similar flickering in the Bitwarden popup panel.
The previous attempt to disable retained-dl just for the scrolled frame didn't work, since we might have already decided not to rebuild OOF frames within the scrolled frame at the point that we added to the dirty area.

That results in the new list containing scrolled content, but not position:fixed content, and then the DAG no longer knows which is on top. It frequently gets it wrong, and things flicker.
Assignee: nobody → matt.woodrow
Attachment #8964222 - Flags: review?(mstange)
Duplicate of this bug: 1450407
Attachment #8964222 - Flags: review?(mstange) → review+
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0cb041700c38
Disable retained display lists when we have overlay scrollbars, as the z-index of the scrollbar changes between paints. r=mstange
I think bug 1450434 might be a dupe of this one.
The new patch in bug 1450360 should fix this.
Flags: needinfo?(matt.woodrow)
Duplicate of this bug: 1450434
Duplicate of this bug: 1450911
Bug 1451971 was filed to track the ESPN issue.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Flags: qe-verify+
Unfortunately, I could not reproduce the issue after several attempts on different builds (20180403100105; 20180403170332; 201804032200400) as well as Latest Nightly 61.0a1 by checking the Facebook bar, Bitwarden popup panel as well as following the STR provided in the duplicate bug 1450911. 

Cameron: Can you please re-check the Facebook bar on the latest Nightly 61.0a1 build and confirm back the results? Any feedback regarding the flickering of the extensions (as you mentioned Bitwarden) would be also much appreciated.
Thank you.
Flags: needinfo?(cam)
These are both fine now, thanks.
Status: RESOLVED → VERIFIED
Flags: needinfo?(cam)
Based on the feedback provided in Comment 14, I will close this issue as Verified Fixed.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.