Closed Bug 1451799 Opened 2 years ago Closed 2 years ago

Tabs that were discarded prior to quitting do not have icons when later restoring the session

Categories

(Firefox :: Session Restore, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1450382
Tracking Status
firefox61 --- affected

People

(Reporter: ke5trel, Unassigned)

References

Details

STR:
1. Install Auto Tab Discard extension.
2. Open some websites in separate tabs.
3. Discard all tabs.
4. Close browser.
5. Open browser and resume last session.

Expected:

All tabs from the previous session should have icons.

Actual:

The tabs that were discarded prior to closing the browser are missing icons.

Users with large numbers of tabs are more likely to want to use tab discarding to conserve resources but losing icons in the process and making tabs harder to distinguish makes it much less appealing.
(In reply to Michael C. Irvin from comment #1)
> Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1427822 ?

That initial bug report is too vague and may not be related to session restoration, it could be something similar to Bug 1450382. This bug is focused on the session restoration case like you mentioned in your comment there which has clear and easy steps to reproduce.

STR modification to make regression finding easier:
4b. Instead of closing the browser, close a window.
5b. Restore window via History -> Recently Closed Windows.
Blocks: 1284886
No longer blocks: 1322485
This is not a regression and goes back to the introduction of the tabs.discard method in Bug 1322485. Bug 1415918 seemed like a possible cause but it was simply preventing tabs from being discarded.
(In reply to Kestrel from comment #2)
> (In reply to Michael C. Irvin from comment #1)
> > Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1427822 ?
> 
> That initial bug report is too vague and may not be related to session
> restoration, it could be something similar to Bug 1450382. This bug is
> focused on the session restoration case like you mentioned in your comment
> there which has clear and easy steps to reproduce.
> 
> STR modification to make regression finding easier:
> 4b. Instead of closing the browser, close a window.
> 5b. Restore window via History -> Recently Closed Windows.

Great point.  Thanks.  

I have screenshots, steps (really same as yours), and the profile (saved locally) I used saved if it helps anyone.  Hopefully we can get this to at least a "confirmed" bug status and prioritized.  (https://bugzilla.mozilla.org/show_bug.cgi?id=1427822#c1)
Component: Tabbed Browser → Session Restore
Maybe add to the dependency tree for bug 120352, 

> Site icon (favicon) tracking bug
Similar bugs:
Bug 1427822
Bug 1453432
Similar bug:
Bug 1450382
At this point it should be fine to dupe this to bug 1450382 already. Thanks for filing!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1450382
You need to log in before you can comment on or make changes to this bug.