Closed Bug 1450382 Opened 2 years ago Closed 9 months ago

loading discarded/pending tabs removes the favicon

Categories

(Firefox :: Tabbed Browser, defect, P3)

60 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: n.gollenstede, Unassigned)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180322152034

Steps to reproduce:

Loading an unloaded (discarded, not yet restored) tab (at least in response to closing a tab) removes its favicon even before it changes it's state to `{ discarded: false }`.
From an UI perspective it wouldn't make a difference to keep the icon untill a new one is found or the tab stops loading (because the icon will be replaced by the page load indicator).

This matters if the page load is aborted, e.g. with `browser.tabs.discard` before a new icon is found. The icon is gone and won't (and can't be with a WebExtension API) restored.
The otherwise meaningless action of shortly focusing a tab in response to another tabs closing before switching to an extension chosen alternative tab thus removes the favicon. This can currently not be prevented or reverted with the WebExtension APIs.

Context:
I am porting this extension: https://addons.mozilla.org/firefox/addon/unloadtabs/
Specifically it's "avoids loading tabs when the active tab is closed" feature.


Actual results:

Favicon is gone.


Expected results:

Favicon should stay / be restored / be restorable.
Component: Untriaged → WebExtensions: Frontend
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Component: WebExtensions: Frontend → Tabbed Browser
Product: Toolkit → Firefox
Duplicate of this bug: 1453432
Similar bugs:
Bug 1427822
Bug 1451799

(Make this bug as a duplicate of one of above bugs)
So any news on this? Is it planned to be fixed?
Duplicate of this bug: 1451799
Has bug 1453751 improved this in Nightly?
Depends on: 1453751
Flags: needinfo?(n.gollenstede)
It seems unchanged. The first update fired when loading a discarded tab is still `{ favIconUrl: null }`.
Ill attach a screenshot that also shows bug 1450371.
Flags: needinfo?(n.gollenstede)
Priority: -- → P3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1427822
See Also: → 1450386

Duplicate Bug 1451799 STR is no longer reproducible on latest Nightly.

Fix window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=740f1995b1281671ca4fe49ad97d834a19d29016&tochange=b342c8e8306e9ab655838f211e18eb65479b29c5

Fixed by: Bug 1441935

Reopen if you still see this on latest Nightly.

Status: NEW → RESOLVED
Closed: 9 months ago
Depends on: 1441935
Resolution: --- → WORKSFORME
Blocks: cuts-control
You need to log in before you can comment on or make changes to this bug.