Closed Bug 1427822 Opened 2 years ago Closed 10 months ago

when discarding a tab, the favicon will sometimes not restore

Categories

(Firefox :: Tabbed Browser, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1450382

People

(Reporter: kernp25, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180103100101

Steps to reproduce:

[1] Install this add-on: https://addons.mozilla.org/firefox/addon/tab-unloader-we/
[2] Check the "Auto unload tabs after" option in the add-on options


Actual results:

Sometimes when a tab is discarded, the favicon is not restored.

It seems there is a problem with tabs.discard?
Component: WebExtensions: General → Tabbed Browser
Product: Toolkit → Firefox
Blocks: 1284886
Priority: -- → P3
All,

I am seeing this as well and when it occurs, it greatly reduces my effectiveness in working with a large number of tabs.

My steps to reproduce (and I can share this profile as it is newly created and reproduces the issue):

* Create new profile (FF 59.0.1)
* Install Tree Style Tab (To show discarded tabs by dimming them) and "Auto Tab Discard" (Uses tabs.discard)
* Set Firefox to restore previous tabs on startup
* Open some tabs
* Let them discard
* Restart the browser

In my case, when I first tried to come up with a reproducible scenario, I would only see like 1 or 2 that would not restore properly until finally after one of the restarts (I did like 3-4 trying different timings and sites), ALL of the favicons would not restore.  Actively loading the tabs loads the favicon properly, but again after they discard and restart the browser they revert back to the default.

I'm seeing a similar behavior with my main browser session and while I understand I am unusual by having hundreds of tabs, having a majority of them with only the default favicon really makes working with them a LOT more difficult.

Loaded:  https://i.imgur.com/0nVkILK.png
Discarded then restarted:  https://i.imgur.com/cwqXyxV.png

I've ZIP-ed up the profile and it is only 8MB and can share if desired.

Sincerely,
Mike

PS. I have only started seeing this in FF59 and am wondering if this could be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1427007 which landed in FF59 and involved fixes to managing Firefox's session.
Maybe add to the dependency tree for bug 120352, 

> Site icon (favicon) tracking bug
Similar bugs:
Bug 1451799
Bug 1453432
Similar bug:
Bug 1450382
Similar bug:
Bug 1458530
The  "sometimes" part of this title got me thinking.  Perhaps FF reloads the the favicon from the internet rather than accessing from cache.  If  one's internet connection is less than perfect, icons could often be lost upon unloading in that context.  It would be better if FF permanently stored favicons for a specific tab until closed or reloaded rather than depending on the net to provide them.  For the user, the favicon is often the tab's identity , especially when that is all you can see when the tab is pinned.  FF should aggressively retain favicons for it's open tabs, a behavior that is vital for people who keep lots of tabs open.
I don't think is an internet thing. The favicons get lost when the tab is unloaded too and there are addons that read the favicons tabs have and after a tab is unloaded and 100% of the time they fail to check what the favicon is on that discarded tab even if the tab shows it, so firefox does something with the favicon when discarding it which is causing the issue.

BTW the favicon for people that uses a lot of tabs I think is very crucial I don't know why this is not given more importance.
Flags: needinfo?(dao+bmo)
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1450382
You need to log in before you can comment on or make changes to this bug.