Closed Bug 1461348 Opened 4 years ago Closed 1 year ago

Allow users to choose which add-on overrides their newtab page in the Preferences.

Categories

(WebExtensions :: Frontend, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1595858
Iteration:
62.3 - Jun 18

People

(Reporter: bwinton, Unassigned)

References

(Blocks 1 open bug)

Details

It would be nice if users could choose which add-on overrides their newtab page, and even nicer if they didn't need to entirely disable the add-on when it wasn't in control.

We have mockups at https://mozilla.invisionapp.com/share/65FPNL9RH4V#/screens/280785532_Explainer which weren't implemented for 61 because of time, I hear, so let's go back and implement them.
I believe these mockups were made by the Activity Stream team but this specific portion of it is falling under WebExtensions. We've looked at these mocks and agree that it is a better solution. We've been discussing what implications this might have for other settings as well but it would indeed be nice to have this one (and the homepage) changed even if we don't update how other settings are handled.

I've added this to the agenda for our Thursday meeting to confirm that we'll move ahead with the New Tab for now.
Assignee: nobody → mstriemer
Blocks: 1342584
Severity: normal → enhancement
Iteration: --- → 62.3 - Jun 18
Component: Preferences → WebExtensions: Frontend
Priority: -- → P1
We discussed this in the Jazz meeting and will look at moving forward here. Some notes:

  * Switching away from an extension will leave the extension enabled.
  * The banner will stay when an extension is selected, but switch the button to say Manage Extensions, rather than Disable Extension.
    * I think this should go to the extension's detail page in about:addons.
  * There was an open question about leaving a message even if the user has switched away from the extension's page. For now we will remove it and can loop back to that later.
Product: Toolkit → WebExtensions
This would still be nice to do but I think P3 is more accurate for its current priority. Removing my assignment since I'm not actively working on this.
Assignee: mstriemer → nobody
Priority: P1 → P3
Duplicate of this bug: 1420944
Is there any workaround for users that want to use add-on overriding New tab page but keeping default Firefox New tab page? 
I'm author of such add-on and some of my users requested this.

This was possible in Firefox 60 where I could navigate to "about:home", but that's blocked now: https://bugzilla.mozilla.org/show_bug.cgi?id=1468191
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1595858
You need to log in before you can comment on or make changes to this bug.