Closed Bug 1463402 (PiP) Opened 5 years ago Closed 11 months ago

Implement Picture-in-Picture Web API

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: beaufort.francois, Unassigned)

References

Details

(Keywords: dev-doc-needed, Whiteboard: [geckoview:p3][webcompat])

User Agent: Mozilla/5.0 (X11; CrOS x86_64 10698.0.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3436.0 Safari/537.36

Steps to reproduce:

Spec: https://wicg.github.io/picture-in-picture/
Explainer: https://github.com/WICG/picture-in-picture/blob/master/explainer.md
Note that https://bugzilla.mozilla.org/show_bug.cgi?id=1280418 is related to this feature request.
Severity: normal → enhancement
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Our stance on this is unclear at the moment. Marking this P3 while we figure it out.
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P3
FYI, here's the latest statement I got from Mozilla: https://github.com/mozilla/standards-positions/issues/72#issuecomment-393596352
Right, thanks. P3 seems appropriate then.
chrome has shipped this on 69 as flag options
and it was activated with 70 by default for the stable release. As a macOS user I hope to get this feature in the next couple months.
Here is some documentation available about Picture-in-Picture support in Chrome 70: 
- https://developers.google.com/web/updates/2018/10/watch-video-using-picture-in-picture
- https://www.chromestatus.com/feature/5729206566649856
Alias: PiP
Depends on: 1280418
Whiteboard: [geckoview:p3]

BBC's site is now using this, as discovered in https://webcompat.com/issues/26256.

Flags: webcompat?
Whiteboard: [geckoview:p3] → [geckoview:p3][webcompat]

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Depends on: 1580095
Depends on: 1601560
Depends on: 1610522
No longer depends on: 1580095
No longer depends on: 1601560
Webcompat Priority: ? → ---
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE

why this bug is marked as duplicate of Bug 1611831?
Picture-in-Picture JavaScript API and disablePictureInPicuture attribute is different things.
e.g. sometimes developer want to add customized "Start PiP" button on their website.

Amininkova, I added the need-info flag for you in order to clarify the question in the previous comment.

Sebastian

Flags: needinfo?(amininkova)

Hi Sebastian and Rinsuki,

Mozilla has no current plans to support Picture-in-Picture Web API or its parts. I will remove the resolution to avoid further confusion but will close the ticket nevertheless.

Flags: needinfo?(amininkova)
Resolution: DUPLICATE → WONTFIX

But from what I heard in the #standard discussion, it seems our standard team recently changed their thought and we might start supporting this API in the future.

It seems incredibly strange to me that Firefox supports picture-in-picture web video but not document.pictureInPictureEnabled + video.requestPictureInPicture(). The end result is that a custom video player cannot show a pip control alongside other custom controls in Firefox, instead having the highly inconsistent floating icon.

Strong +1 towards supporting the PIP API, please.

Hi,
I don't really get why you wont at-all support the disablePictureInPicture attribute. We have built a WebRTC conference application and the usability is completely broken since every participant's video has this ridiculous floating PiP overlay, that completely interferes with the UI and just confuses our users.
The fact that we can not even disable it for video elements that display a WebRTC MediaStream brought us to the decision that we will no longer support Firefox and will recommend the usage of other browsers to our customers.

Hi Sven! Note that this is the meta-issue for the implementation of all the PiP API (which unfortunately also got closed because Mozilla obviously doesn't have any plans to implement this API, for the time being).
The specific bug for disablePictureInPicture is/was bug 1611831. See Mike Conley's comments there for Mozilla's reasoning not to implement this API. He also mentions there that an enterprise policy got introduced in bug 1619658 that allows system administrators to turn the the PiP overlay off. Users can also individually disable the button in the settings by unchecking the option "Enable picture-in-picture video controls".

Sebastian

You need to log in before you can comment on or make changes to this bug.