Closed Bug 1469023 Opened 2 years ago Closed 2 years ago

Show "new changes since (datetime)" indicator that links to unread changes/comments

Categories

(bugzilla.mozilla.org :: User Interface, enhancement)

Production
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: kohei.yoshino, Assigned: kohei.yoshino)

References

(Blocks 2 open bugs)

Details

(Keywords: bmo-ux)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
Details | Review
Currently show_bug.cgi uses the Bug User Last Visited API [1] to update the user’s last visited timestamp, but the API also allows to get the last visited timestamp. By now people are familiar with Slack showing the blue “New comments since (date)” indicator on each channel, and some other messaging apps do the same thing. It’s listed on roc’s wish list [2] and my Bugzilla 6 roadmap [3], and it should be easy to get implemented with no backend changes.

[1] https://bmo.readthedocs.io/en/latest/api/core/v1/bug-user-last-visit.html
[2] https://robert.ocallahan.org/2013/01/optimizing-bugzilla-usage.html
[3] https://github.com/bugzilla/bugzilla-ux/wiki/Bugzilla-6-Roadmap
Severity: normal → enhancement
Attached file pull request
I've removed the auto-scroll, because the bug header is not fix-positioned yet and users won't be able to see the bug summary when scrolled down. Once the page layout is optimized like Slack [1], auto-scroll can be put in place for faster browsing.

[1] https://get.slack.help/hc/en-us/articles/217626358-Tour-the-Slack-app
Summary: Show "New comments since (date)" indicator and scroll down the comment feed → Show "new changes since (datetime)" indicator that links to unread changes/comments
Merged to master, will ship today.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1471593
Depends on: 1471966
See Also: → 1472450
Depends on: 1481106
Blocks: 176145
No longer depends on: 1481106
See Also: → 1481106
No longer blocks: 176145
Duplicate of this bug: 176145
Duplicate of this bug: 294413
Depends on: 1532482
Blocks: 1533582
Blocks: 1534087
Depends on: 1542936
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.