Closed Bug 1481106 Opened 4 years ago Closed 3 years ago

Start logging bug_user_last_visit for all visited bugs even if the user is not involved

Categories

(bugzilla.mozilla.org :: API, task)

Production
task
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: kohei.yoshino, Assigned: kohei.yoshino)

References

(Blocks 3 open bugs)

Details

(Keywords: ux-consistency)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
Currently we are logging bug_user_last_visit only on bugs the user is involved in some way (reporter, assignee, QA contact, mentor or CC.) But since we have the Component Watching extension, there might be many cases people watching bugs without adding themselves to the CC list.

The API use cases:

* It has already been used to show “new changes/comments since” indicator, and it seems people like it. (Bug 1469023)

* Also, an enhanced quick search bar under development will show recently visited bugs for easier access. (Bug 1472565)

Basically people don’t care about whether they are CCed in a particular bug or not. A visit is a visit. The unavailability of those features due to their uninvolvement is against user’s expectations. So I’d like to get rid of the limitation and start logging on any bugs they have visited.

dylan: any concerns?
Flags: needinfo?(dylan)
Keywords: ux-consistency
Assignee: nobody → kohei.yoshino
No longer blocks: 1472565
No longer blocks: 1469023
See Also: → 1469023, 1472565
See Also: → 1531517

I’d like to move this forward given several use cases mentioned in my Comment 0, Bug 1472450 and Bug 1531517.

Blocks: 1472565, 1529362
Status: NEW → ASSIGNED
See Also: 1472565
Summary: Consider logging bug_user_last_visit for all bugs → Start logging bug_user_last_visit for all visited bugs even if the user is not involved
Blocks: 1472450
Attached file GitHub Pull Request
Flags: needinfo?(dylan)
Blocks: 1533582

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Regressions: 1541123
Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.