Last Comment Bug 147015 - JS Console should group same errors
: JS Console should group same errors
Status: RESOLVED DUPLICATE of bug 80704
:
Product: Toolkit Graveyard
Classification: Graveyard
Component: Error Console (show other bugs)
: Trunk
: All All
-- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 206874 (view as bug list)
Depends on: 228205
Blocks: 65469 490886
  Show dependency treegraph
 
Reported: 2002-05-25 06:59 PDT by Mark Slater
Modified: 2016-06-29 11:02 PDT (History)
13 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Mark Slater 2002-05-25 06:59:16 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020524
BuildID:    2002052408

It would be nice if the JS Console would group javascript errors that are
exactly the same, eg. if some site's JS has 1'000 instances of the same
occurring error, the JS console shouldn't fill itself with 1'000 errors, but
group it under 1 error message with a twisty to show all 1'000 instances of the
error.
Comment 1 User image Matthew Cline 2002-06-06 19:44:15 PDT
I don't think this would be a good default behavior, since the significance of a
much repeated error might depend upon the errors imediatly before and after it.
However, a checkbox in the JS console to turn this on would be a good idea.

Confirming as NEW, changing Platform/OS to "All/All".
Comment 2 User image Boris Zbarsky [:bz] (still a bit busy) 2004-02-28 18:24:21 PST
Perhaps the right thing to do here is exponential backoff (possibly in the
console service itself)?  That is keep track of errors we've seen.  If we get
one just like one we already got, and we've gotten it a lot recently (the exact
definitions of "a lot" and "recently" are up for debate") we ignore it.  This
way as long as an error is repeating we will report it, but say no more often
than once a second (or whatever "recently" is), though in the first second of
reporting, for example, it we would report it as many times as it happens.

Thoughts?

We really do want something like this on by default if we're going to turn on
CSS error reporting in release builds....
Comment 3 User image Boris Zbarsky [:bz] (still a bit busy) 2004-05-02 23:05:36 PDT
*** Bug 206874 has been marked as a duplicate of this bug. ***
Comment 4 User image Stefan Breunig 2005-10-08 16:32:52 PDT
Rather than setting some values for "a lot" and recently I'd say that an error
isn't displayed if it matches the previous one. If it doesn't, a new one is
created, otherwise just increase a counter.

eg:
CSS Error 1
CSS Error 2
[5] JS Error 1
JS Error 2
[19] JS Error 1

If you mean by "ignore an error" do not display it, then I can't agree. At least
there needs to be a visible change, or some info that this error just occured
again. Imagine you got a link list where's a Javascript onmouseover error. It
maybe would report the first 10 entries, or however many get triggered
"recently" and then it would stop - could be confusing. Moreover
blocking/ignoring the errors after 10 repetitions or after there were "a lot"
"recently" only reduces the error spam instead of completely removing it.
Imagine the error occurs all "recently"+1 times, having it displayed all the
time though no new information is displayed.
Comment 5 User image Stefan Breunig 2005-10-08 16:48:12 PDT
Is this bug  a dublicate of bug 80704 - both are about removing dublicate
entries in JS console
Comment 6 User image Philip Chee 2010-05-04 01:13:20 PDT

*** This bug has been marked as a duplicate of bug 80704 ***

Note You need to log in before you can comment on or make changes to this bug.