Closed Bug 147404 Opened 22 years ago Closed 20 years ago

Option to reload the tabs of the last closed Mozilla window

Categories

(SeaMonkey :: Tabbed Browser, enhancement)

x86
All
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 39165

People

(Reporter: rob.stow, Assigned: jag+mozilla)

References

Details

Mozilla has had a critical bug for a long time for which
a solution does not appear to be forthcoming:  when you
have a window with multiple tabs open and you accidentally
close the window when your intention was merely to close 
one tab, you end up losing your entire browsing session.

Spent hours tracking down a site that sells that old LP 
you wanted to add to your collection ? Tough.  You are 
screwed.

Until this bug gets fixed, I propose a recovery method.
The technique used to do this is also potentially useful 
even after that bug gets fixed.

I propose that EVERY time you close a Navigator window
Mozilla will save a list of what you had open in the tabs
of that window.   Let's call this the "Last Window Session".
Now add an item to the menu - perhaps under "BookMarks" -
called "Reload last Window Session".

Note this has potential uses outside of disaster recovery.
For example, I am waiting until I am done with the tabs I
currently have open in this Navigator window so that I can
close Mozilla and use Profile Manager.   It would be nice
if I could simple close Mozilla without having to wait, and
then come back and just reload that "Last Window Session".

I do NOT want to set Mozilla to _always_ load my "Last Window
Session" - I want it to load my home page unless I tell it
otherwise.
duping against bug 108973:
[RFE] Multi-tabbed windows should confirm close

*** This bug has been marked as a duplicate of 108973 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
#147404 is NOT a duplicate of this #108973.   Who ever
labeled it as a duplicate obviously did not read 
it first.

#147404 is a request for a feature that CAN be used as a
work-around for this bug (#108973).   It however has other 
uses - as would be noticed by anyone who actually read
#147404.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Agreed.  If a fix for this bug is checked in, a user may *intentionally* close a
window full of tabs knowing full well that they will lose all sites - but be
able to get back to them again in their next session.  This bug works in
conjunction with bug 108973 (which is about *unintentionally* closing a window
full of tabs), but is not a duplicate.
The history window might be useful to you in the mean time.  I'm not thrilled
with the way history is organized, but it's better than nothing.
To tabbed browser.
Assignee: Matti → jaggernaut
Status: UNCONFIRMED → NEW
Component: Browser-General → Tabbed Browser
Ever confirmed: true
QA Contact: imajes-qa → sairuh
The history window is also far from being a comprehensive list of where you have
been.   For example, in my first Mozilla session today I _KNOW_ I went to 
CNNSI's Golf page,  ESPN's Baseball page, ESPN's NBA page, Tom's Hardware Guide,
2cpu.com, ncix.com, and IDG.net.  None of those are shown in the history window.

I visit Tom's Hardware Guide, 2cpu.com, TechReports and a few others virtually
every day and they are not in my history for the last three days - which is as
far back as I can go because Mozilla RC3 trashed my profile not long after I
installed it.  (Yes, I do back up my profile regularly - just not the history
and the cache.)
Dupe of bug 147030? 
I'd question the need for a menu item for the last closed window, and I don't
see why we'd only have one of these objects, but augmenting history with the
equivalent of groupmarks for windows that were closed with multiple tabs is an
interesting idea.   If we kept track of all such windows, you could just go to
History and click on one to load them again. 
Re: Comment #7 (Dupe of #147030 ?)

No - but very close.   Stage one of the process is the same 
to satisfying both of these requests:   automagically save
the set of tabs currently open when you close Mozilla.

Stage two is where they differ:  

#147030 wants Mozilla to automatically reload that saved session 
when Mozilla is next started.   This would be a powerful extension 
of the option in Edit|Preferences|Navigator|When Navigator starts 
up display==>Last Page Visited.

#147404 wants Mozilla to NOT automatically load that saved session.
Instead it wants an menu option that lets the user manually cause 
that saved session to be reloaded on a case-by-case visit. 

Examples: I normally want Mozilla to open to my home page, but ...
1:  once in a while I want to be able to reload that saved
session because I accidentally closed Mozilla when all I
intended to do was close a single tab.
2:  once in a while I want to intentionally close a multi-tabbed
Mozilla session and still be able to recall it next time you load
Mozilla.  This can come in handy when:
  2a)  You need to exit Mozilla to use Profile Manager.
  2b)  You need to exit Mozilla to edit prefs.js or user.js or
       userChrome.css or see the effect of a theme change or ...
3:  What if Mozilla was forced to shut down while you were away from
your computer ?  Network/SysAdmins can cause this to happen in a 
variety of ways - timed delays, network shutdowns, etc.  Maybe
another user just sat down at your computer and logged you off so 
he could log on ?
  




*** Bug 147030 has been marked as a duplicate of this bug. ***
*** Bug 147385 has been marked as a duplicate of this bug. ***
This can be done using
Multizilla
http://multizilla.mozdev.org

No need for doing it again in Mozilla.
Question: If you have multiple sessions open (say multiple tabs in each) and
exit via File -> Exit, what should happen when Mozilla is restarted?  Which of
the following should happen:

a) Reload all sessions, each with its set of tabs.
b) Reload just the focused session with its tabs when it was Mozilla was closed.
c) Reload all tabs from every session but all into the single, new session.
d) User choice of above.
I'd vote for (b).  But I'd also say that in order for (b) to work well, 
Mozilla's 'open new links as tabs' preference would actually need to work 
right, both for JS/target=_blank window openings and MailNews links.  Then 
there would be a minimum of superfluous extra open Moz windows which are not 
part of the "main" single multitabbed browsing session.

:)

I would personally prefer b) also, but I thought that I'd clarify the situation.
How about recording the URLs of opened (not when closed) and not properly closed
tabs/windows, so that if Moz crashes, I can run it again and select "open last
session's URLs". Moz should not automatically open all pre-crash URLs since one
of them might be responsible for the crash. Add as new rfe?
QA Contact: sairuh → pmac
Jeandré, that's a good idea. Perhaps you should file a separate RFE
and make it dependent on this bug and bug 108973?

btw, per bug 147385, which is resolved as dupe of this bug, does
this bug refers to the "last page visited" preferences option?
Severity: enhancement → trivial
Summary: RFE: option to reload the tabs of the last closed Mozilla window → Option to reload the tabs of the last closed Mozilla window
oops
Severity: trivial → enhancement
*** Bug 181071 has been marked as a duplicate of this bug. ***
See also bug 39165, "ability to open last closed window".

*** This bug has been marked as a duplicate of 39165 ***
Status: NEW → RESOLVED
Closed: 22 years ago20 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.