Show card network logos on the card add/edit screens

VERIFIED FIXED in Firefox 64

Status

()

P1
enhancement
VERIFIED FIXED
8 months ago
6 months ago

People

(Reporter: MattN, Assigned: sfoster)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified)

Details

(Whiteboard: [webpayments])

User Story

* Use actual network logos
* Hide the accepted cards display if the merchant didn't have a preference (summary, edit and add new payment method screens)
** Move the logic into the custom element since it's not context-specific?

Attachments

(2 attachments)

The details are still being sorted out but we will want card network logos on the payment summary and/or basic card add/edit screens.
Depends on: 1429181
See Also: → bug 1490807
Summary: Show card network logos on the payment summary and/or card add/edit screens → Show card network logos on the card add/edit screens
Priority: P3 → P2
Priority: P2 → P3
Whiteboard: [webpayments-reserve] → [webpayments-reserve]
Priority: P3 → P2
Whiteboard: [webpayments-reserve] → [webpayments]
(Assignee)

Comment 1

6 months ago
Bug 1429181 uses a placeholder treatment for the "merchant accepts: " logos on both the summary and add/edit card pages. This bug should replace those with real image assets. 

Eric, I'm flagging you just so you know where to let me know when you have these ready.
Flags: needinfo?(epang)
(Assignee)

Updated

6 months ago
Blocks: 1473662
No longer depends on: 1473662
Please provide all the logos in bug 1392520 to keep them all in one place.
Depends on: 1392520
Are we supposed to hide the "Merchant accepts" section from the add form when the merchant doesn't provide a list (and therefore all are accepted)?
User Story: (updated)
(Assignee)

Comment 4

6 months ago
(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #3)
> Are we supposed to hide the "Merchant accepts" section from the add form
> when the merchant doesn't provide a list (and therefore all are accepted)?

Yes that whole line should be hidden if there's no supportedNetworks in the payment methods we get. We (now) have tests that should confirm this is the case. Can you file a bug if you see otherwise?
(Assignee)

Comment 5

6 months ago
(In reply to Sam Foster [:sfoster] from comment #4)
> (In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from
> comment #3)
> > Are we supposed to hide the "Merchant accepts" section from the add form
> > when the merchant doesn't provide a list (and therefore all are accepted)?

I've implemented hiding this line for the summary page, but I think not for the add/edit card page. Maybe that was the question for UX?
Right, we only implemented for the summary page, so that was a question for UX and this bug can already handle addressing the answer.
If the merchant doesn't provide a list then we should hide it for the summary, edit and add new payment method screens. thanks!
Flags: needinfo?(epang)
User Story: (updated)
Flags: qe-verify+
QA Contact: hani.yacoub
(Assignee)

Updated

6 months ago
Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 9012416 [details]
Bug 1477102 - Toggle accepted cards list on add/edit cards. Add stub for using AppConstants.MOZILLA_OFFICIAL to fallback for non-branded builds. r?MattN

Matthew N. [:MattN] (PM me if requests are blocking you) has approved the revision.
Attachment #9012416 - Flags: review+
Comment on attachment 9012417 [details]
Bug 1477102 - Add third-party payment card logos, enable their use in official, branded builds. r?MattN

Matthew N. [:MattN] (PM me if requests are blocking you) has approved the revision.
Attachment #9012417 - Flags: review+
Attachment #9012416 - Attachment description: Bug 1477102 - Toggle accepted cards list on add/edit cards. Add stub for using appinfo.isOfficialBranding to fallback for non-branded builds. r?MattN → Bug 1477102 - Toggle accepted cards list on add/edit cards. Add stub for using AppConstants.MOZILLA_OFFICIAL to fallback for non-branded builds. r?MattN
Attachment #9012417 - Attachment description: Bug 1477102 - Add payment card logos with license details, enable their use in official, branded builds. r?MattN → Bug 1477102 - Add third-party payment card logos, enable their use in official, branded builds. r?MattN

Comment 12

6 months ago
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ce23e4daf8d
Toggle accepted cards list on add/edit cards. Add stub for using AppConstants.MOZILLA_OFFICIAL to fallback for non-branded builds. r=MattN
https://hg.mozilla.org/integration/autoland/rev/04f74c53d537
Add third-party payment card logos, enable their use in official, branded builds. r=MattN

Comment 13

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6ce23e4daf8d
https://hg.mozilla.org/mozilla-central/rev/04f74c53d537
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64

Comment 14

6 months ago
Card network logo that Merchants accepts are displayed in summary page, edit and add payments method. Tested this part on this test page "https://paymentrequest.show/demo/".

On this test page "https://rsolomakhin.github.io/pr/single/" I verified that the accepted cards aren't displayed if the merchant didn't have a preference (summary, edit and add new payment method screens).

But in case I added a new card (Visa for example), and Visa isn't supported. I added Visa card number but I select form "Card Type" drop down a supported network(Master for example).
Is it OK in this case to be validated as a correct card? Is this handled in another bug and the first two things verified above is sufficient to mark this bug as verified?
Flags: needinfo?(sfoster)
(Assignee)

Comment 15

6 months ago
(In reply to Hani Yacoub from comment #14)
> But in case I added a new card (Visa for example), and Visa isn't supported.
> I added Visa card number but I select form "Card Type" drop down a supported
> network(Master for example).
> Is it OK in this case to be validated as a correct card? Is this handled in
> another bug and the first two things verified above is sufficient to mark
> this bug as verified?

Yes and yes, that is bug 1494564.
Flags: needinfo?(sfoster)
(Assignee)

Updated

6 months ago
Blocks: 1495530

Comment 16

6 months ago
Hi Sam!

Further testing revealed that the "Merchant accepts:" string is missing on Ubuntu 16.04. Only the logo images are displayed. Should I submit a new issue for this or can it be handled in an existing one?
Flags: needinfo?(sfoster)
(Assignee)

Comment 17

6 months ago
(In reply to Timea Babos from comment #16)
> Hi Sam!
> 
> Further testing revealed that the "Merchant accepts:" string is missing on
> Ubuntu 16.04. Only the logo images are displayed. Should I submit a new
> issue for this or can it be handled in an existing one?

I'm not able to reproduce that. Can you file a new bug with a screenshot, the test page you were using and any details you can add to help reproduce?
Flags: needinfo?(sfoster) → needinfo?(timea.babos)

Comment 18

6 months ago
Hey Sam,

I tried to reproduce it once more but didn't manage to. :(
Will file a new bug if it occurs again and I can get reliable steps. 

Will close this issue as Verified - Fixed on all OSes.
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
Flags: qe-verify+
Flags: needinfo?(timea.babos)
You need to log in before you can comment on or make changes to this bug.