Closed Bug 1477676 Opened 2 years ago Closed 1 year ago

Remove internal bookmarks support for live bookmarks

Categories

(Firefox :: Bookmarks & History, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 65

People

(Reporter: Gijs, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [overhead:noted][fxsearch])

Once we no longer have UI or sync ways to create new live bookmarks, and have migrated user data, we can remove all the backend support for live bookmarks.
Priority: -- → P2
Blocks: 1460577
Duplicate of this bug: 1468861
Blocks: 1469698
Whiteboard: [overhead:noted]
This will likely happen in Firefox 65, we can live with the code for a while even if it will be partly unused.
Whiteboard: [overhead:noted] → [overhead:noted][fxsearch]
Priority: P2 → P1
Depends on: 1501811
Depends on: 1502655
Depends on: 1502954
Let's name this fixed, we can handle eventual leftovers in new bugs, if we notice them.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.