Improve messaging for changing the selected lang pack

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P1
normal
RESOLVED FIXED
9 months ago
5 months ago

People

(Reporter: mstriemer, Assigned: mstriemer)

Tracking

(Blocks 1 bug)

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

9 months ago
There's a message bar that prompts the user to restart once they've changed their langpack. Currently this message is displayed in the language that will be used after restart.

We may want to include both the current language and the language that will be used after restart.

We also may want to have a "Cancel" button.

The message bar should maybe be the yellow "warning" one instead of the grey "info" version so that it is more prominent.
(Assignee)

Updated

9 months ago
No longer blocks: 1469684
Depends on: 1469684
(Assignee)

Updated

8 months ago
Priority: P2 → P1
(Assignee)

Comment 1

7 months ago
How would you like to format this message with both languages? We could do the same as attached image. Do you have any concerns about following that approach?
Flags: needinfo?(emanuela)

Comment 2

7 months ago
(In reply to Mark Striemer [:mstriemer] from comment #1)
> How would you like to format this message with both languages? We could do
> the same as attached image. Do you have any concerns about following that
> approach?

Each message should be a paragraph. The message is first displayed in the requested language (e.g. Italian) and then in the previous one (e.g. English). Instead of putting the second language in brackets, I'd like to see how it looks in italic. 

In the button, we can separate the languages with `|`
Flags: needinfo?(emanuela)
Note that Italic might be a problem with non Latin scripts.

Comment 4

7 months ago
(In reply to Francesco Lodolo [:flod] from comment #3)
> Note that Italic might be a problem with non Latin scripts.

That's a great point. 
Maybe just having them on different paragraphs is enough.
(Assignee)

Comment 6

6 months ago
Posted image German-English.png
Here's a screenshot with German and English shown.
Blocks: 1505727
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1505727

Comment 8

5 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfabda09e4a7
Include both languages in the browser language switch confirmation r=jaws

Comment 9

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bfabda09e4a7
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Assignee)

Updated

5 months ago
Depends on: 1509080
You need to log in before you can comment on or make changes to this bug.