Closed Bug 1486220 Opened 2 years ago Closed 2 years ago

Video controls are not functioning

Categories

(Firefox :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- verified

People

(Reporter: darkspirit, Assigned: bgrins)

References

(Depends on 1 open bug, )

Details

(Keywords: nightly-community, regression)

Attachments

(1 obsolete file)

mozregression --good 2018-08-24 --bad 2018-08-25 -a https://img-9gag-fun.9cache.com/photo/aGjm9XG_460svvp9.webm
> 2:24.14 INFO: Last good revision: d3e3d5942e1b4a70963157c7000816c3ca0e604f
> 2:24.14 INFO: First bad revision: 3bc799b58c46ae66563ffc0f1b8f7b206b7dc587
> 2:24.14 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d3e3d5942e1b4a70963157c7000816c3ca0e604f&tochange=3bc799b58c46ae66563ffc0f1b8f7b206b7dc587

> 3bc799b58c46	Brendan Dahl — Bug 1485426 - Use createXULElement instead of createElement in XUL docs. r=bgrins
Flags: needinfo?(bdahl)
See Also: → 1486237
Thanks for the report, I'll take a look at this.
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bdahl) → needinfo?(bgrinstead)
Duplicate of this bug: 1486260
Since videocontrols run in content, this is generally an HTML document.
I'm surprised this wasn't caught by mochitests - I'm guessing they are chrome priv and so had access to createXULElement. This needs a regression test but I'll file another bug for that so we can get this landed ASAP.
Flags: needinfo?(bgrinstead)
Depends on: 1486277
Duplicate of this bug: 1486237
Attachment #9004080 - Attachment description: Bug 1486220 - Revert document.createXULElement change in videocontrols.xml;r=Gijs → Bug 1486220 - Revert document.createXULElement change from Bug 1485426 in videocontrols.xml;r=Gijs
Attachment #9004080 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/b2d0cb1ce26f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
I have managed to reproduce this issue using Firefox 63.0a1 (BuildId:20180825220457).

This is verified fixed using Firefox 63.0b7 (BuildId:20180917143811) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.