visible (non-transparent) gray square corners are now sticking out from curved titlebar corners, on Ubuntu 18.10

RESOLVED FIXED in Firefox 66

Status

()

defect
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: dholbert, Assigned: stransky)

Tracking

(Depends on 3 bugs, Blocks 1 bug, {regression})

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 wontfix, firefox66+ fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 months ago
Posted image screenshot of bug

STR:

  1. Start Firefox, in Ubuntu 18.10
  2. Drag the window over a dark background, and look at the upper left and upper right corners of the titlebar.

EXPECTED RESULTS:
Corners should be rounded.

ACTUAL RESULTS:
Corners are rounded, but there's a gray area jutting out beyond the rounded edge, "filling in the square" so to speak.

See attached screenshot.

This is a regression from bug 1490344. [confirmed via mozregression]

(You may notice that the "x" icon is mispositioned, too -- I filed that separately as bug 1521010.)

(Reporter)

Comment 2

3 months ago

I'm using Ubuntu 18.10 with the default theme (Yaru).

(Reporter)

Updated

3 months ago
Flags: needinfo?(stransky)
(Assignee)

Comment 3

3 months ago

It's caused by Bug 1516224 - we disabled transparent background on Basic compositor due to this, I'll look at it. We should disable the default hidden titlebar (bug 1490344) for the upcoming beta if it's not fixed in time.

Assignee: nobody → stransky
Blocks: gtktitlebar
Flags: needinfo?(stransky)
(Assignee)

Comment 4

3 months ago

I think I have a fix for it so we can leave the system titlebar disabled.

(Assignee)

Comment 6

3 months ago

To support rounded corners of Gtk+ titlebar themes (Adwaita, Radiance..) in GNOME we need to use X shape mask
as fully transparent toplevel window causes various issues (like Bug 1516224).

We draw mShell as transparent and mContainer as non-transparent with shape mask applied. The shape mask
is generated only when titlebar rendering is enabled and it's generated from GtkHeaderBar Widget
to match the exact look.

We use existing mTransparencyBitmap for the shape mask where mTransparencyBitmapForTitlebar controls
whether it's a general shape mask or our specialised shape for titlebar only.

This is already enabled for GNOME environment by default. So there's a new preference
widget.default-hidden-titlebar added to easily disable it if any issue appears
during testing.

(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Hi, landing failed with the following message:

On Wed, January 23, 2019, 1:00 PM GMT+2, by dvarga@mozilla.com.
Revisions: D17283 diff 54116
Details: We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpDBvk69\npatching file widget/gtk/nsWindow.cpp\nHunk #3 FAILED at 3234\n1 out of 10 hunks FAILED -- saving rejects to file widget/gtk/nsWindow.cpp.rej\nabort: patch failed to apply', '')

Flags: needinfo?(stransky)
Keywords: checkin-needed
(Assignee)

Comment 9

3 months ago

Updated, Thanks.

Flags: needinfo?(stransky)
Keywords: checkin-needed
(Assignee)

Comment 10

3 months ago

I'll update the formatting.

Keywords: checkin-needed
(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Comment 11

3 months ago

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64d38928ff5a
[Linux/GNOME] Use X shape mask to draw transparent corners when we draw to titlebar, r=lsalzman

Keywords: checkin-needed
Duplicate of this bug: 1521473

Comment 14

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Updated

3 months ago
Depends on: 1522774

Noticed a perf improvement! \0/

== Change summary for alert #18853 (as of Wed, 23 Jan 2019 14:09:39 GMT) ==

Improvements:

3% sessionrestore linux64 pgo e10s stylo 315.38 -> 307.25

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18853

Depends on: 1523556

Updated

3 months ago
Depends on: 1523560

Updated

3 months ago
Depends on: 1525233

Updated

2 months ago
Depends on: 1526217

Updated

2 months ago
Blocks: 1339150
Depends on: 1527315
You need to log in before you can comment on or make changes to this bug.