Closed Bug 1516224 Opened 9 months ago Closed 8 months ago

Semi-Transparent YouTube video playback

Categories

(Core :: Widget: Gtk, defect)

64 Branch
Unspecified
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- wontfix
firefox65 + verified
firefox66 + verified

People

(Reporter: jorgecszabo, Assigned: stransky)

References

(Depends on 1 open bug)

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

I try to watch a YouTube video in Firefox 64 in Ubuntu 18.04 GNOME. I'm using the Nvidia drivers 415 and the lastest system updates available in Ubuntu.
This is a video were the issue is clear: https://www.youtube.com/watch?v=grEKMHGYyns


Actual results:

The video plays fine, but there is a transparency that lets me see a silhouette of the window that is open in the back. I've attached a screenshot of the issue that makes it look clear. I have also tried disabling hardware acceleration, but I get exactly the same results.


Expected results:

The video to play without any traces of the windows open in the back of Firefox. In the case of the screenshot the background should look completely grey (works like that in Chromium and Firefox for Windows)
I can observe the same problem on Arch Linux with firefox 64.0 and Nightly, on both Gnome and KDE Plasma.
Additionally I've just reproduced it in a clean and updated Ubuntu 18.04 VM.

I also notice that the video is only transparent while its playing, but not paused.
See Also: → 1516129
OS: Unspecified → Linux
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
I can reproduce on Nightly66.0a1 Ubuntu 18.04 VM with clean profile.
(Host OS: Windows10 1809 64 bit, Guest OS: Ubuntu 18.04 64bit)

Steps to Reproduce:
1. Open any page(includes dark image) on Nightly66 or Chromium and Maximized
   e.g. http://www.maryctaylor.com/portfolio_page/flipt-pictures-girl/

2. Open Firefox64 with new profile and maximized
3. Open https://www.youtube.com/watch?v=uI6EQjXwYR8
4. Switch to Fullscreen of the video (or Theater mode or Default mode).

5. Observe ghost image while the video playing

Actual Results:
Ghost images appears while the video is playing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have been able to reproduce this on a Thinkpad E440 running Ubuntu 18.04 and Firefox 64. The machine has Intel integrated graphics and is running the latest drivers available.
Regression window with mozregression:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4ac589d31bd7598bfa67f5fb64bdf1517d5dd8a4&tochange=14c5eab0c6b359b7904a8d9807c8282352707ba0

Regressed by: 14c5eab0c6b3	Martin Stransky — Bug 1489097 - [Linux/Gtk] Enable default ARGB visual for toplevel windows on GNOME, r=jhorak

:stransky,
Your patch seems to cause the regression. Can you please look into this?
Blocks: 1489097
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Audio/Video: Playback → Widget: Gtk
Flags: needinfo?(stransky)
Duplicate of this bug: 1516129
[Tracking Requested - why for this release]: Youtube video glitches.


WORKAROUND:
Create mozilla.widget.use-argb-visuals as Boolean and set it to false in about:config. And then restart browser.
also affected to Ubuntu 18.10
Sure, I'll look at it.
Assignee: nobody → stransky
Flags: needinfo?(stransky)
Yes I can see it now, Thanks.

Hi Martin, just FYI, we have one 65 Beta build left this week (Thursday) before next week's RC.

Flags: needinfo?(stransky)

This happens with WindowSurfaceX11SHM SW compositor only. I think we should disable ARGB visual in this case.

Flags: needinfo?(stransky)
Keywords: checkin-needed

Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d104c49d7e2
[Linux/Gtk] Disable ARGB toplevel visual on X11 SW compositor due to visible graphics artifacts, r=lsalzman

Keywords: checkin-needed

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(stransky)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Comment on attachment 9036586 [details]
Bug 1516224 - [Linux/Gtk] Disable ARGB toplevel visual on X11 SW compositor due to visible graphics artifacts, r=lsalzman

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1489097

User impact if declined: Visible graphics artifacts when playing video on Linux with WindowSurfaceX11SHM compositing (which is default on Linux).

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: 1) disable layers.acceleration.force-enabled if you have enabled it
2) open any application (terminal...)
2) open Firefox and play https://www.youtube.com/watch?v=uI6EQjXwYR8 on fullscreen
3) watch if there's a visible artifacts of the backgroun application from step 2

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Linux only, disables ARGB visual by default which was state before Bug 1489097

String changes made/needed: none

Flags: needinfo?(stransky)
Attachment #9036586 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9036586 [details]
Bug 1516224 - [Linux/Gtk] Disable ARGB toplevel visual on X11 SW compositor due to visible graphics artifacts, r=lsalzman

[Triage Comment]
Fix for artifacts when playing video on Linux with WindowSurfaceX11SHM compositing. Approved for 65.0b12.

Attachment #9036586 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Managed to reproduce this issue on FF 64.0.2 on Ubuntu 18.04x64.

Confirming this bug verified fixed on 65.0b12 (buildid:20190116191407)and on the latest Nightly 66.0a1. Verified on Ubuntu 18.04x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1521473

Side effect of the fix, now areas of the window that are supposed to be transparent aren't anymore. Is that just unavoidable? https://i.imgur.com/OGaQD3S.png

(In reply to burritosaur from comment #22)

Side effect of the fix, now areas of the window that are supposed to be
transparent aren't anymore. Is that just unavoidable?
https://i.imgur.com/OGaQD3S.png

Unfortunately yes, unless the video playback is fixed (and other possible content glitches). See Bug 1521012 for details - it fixes the corners a bit.

Duplicate of this bug: 1521422
Depends on: 1524156
See Also: → 1568569

Bug 1568569 is related and applies to fullscreen playback.

I can reproduce this on Ubuntu 18.04, Firefox 69, and nvidia-435. Do you want a new bug report?

You need to log in before you can comment on or make changes to this bug.