Closed Bug 1499947 Opened Last year Closed 11 months ago

kill xul:progressmeter

Categories

(Core :: XUL, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: surkov, Assigned: Paolo)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(2 files)

as long as bug 1428869 is fixed, we can kill progressmeter CE (see bug 1491197). 

So 
* rollback bug 1491197
* remove all XULProgressMeterAccessible references https://searchfox.org/mozilla-central/search?q=XULProgressMeterAccessible&case=true&path=
* remove <progressmeter> from XUL testing files https://searchfox.org/mozilla-central/search?q=%3Cprogressmeter&case=true&path=*.xul
Summary: kill progressmeter CE → kill xul:progressmeter
There's also the XUL frame and some appearance code that looks for XUL attributes.
Blocks: war-on-xbl
Priority: -- → P4
I spawned off removing the XUL frame as bug 1504576.
Depends on: 1504576
Depends on: 1505590
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: P4 → P1
Depends on: 1507829
Duplicate of this bug: 1505590
Blocks: 1508646
When this lands, uses of the XUL "progressmeter" in comm-central would have to be replaced with the HTML "progress" element, or the current Custom Element could be moved there.
Flags: needinfo?(jorgk)
Thanks for the heads-up. I thought we had already replaced all progress metres with HTML in bug 1499593. I'm not missing anything here, am I, Richard?
Flags: needinfo?(jorgk) → needinfo?(richard.marti)
Is this returning stale results?

https://dxr.mozilla.org/comm-central/search?q=%3Cprogressmeter
(In reply to :Paolo Amadini from comment #10)
> Is this returning stale results?
> 
> https://dxr.mozilla.org/comm-central/search?q=%3Cprogressmeter

The footer says last updated at 2018-11-19 22:51. 

Better to use https://searchfox.org/comm-central/search?q=%3Cprogressmeter&case=false&regexp=false&path=

Which shows only one <progressmeter which landed in bug 1496632 after our port to html. So only this needs to be fixed.
Flags: needinfo?(richard.marti)
Blocks: 1508735
No longer blocks: 1508735
Depends on: 1508735
Thanks again, I wasn't aware of the last one which had crept in. Filed bug 1508735 for its removal.
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0f64862fa1c3
Part 1 - Remove XULProgressMeterAccessible and its base template class. r=Jamie
https://hg.mozilla.org/integration/mozilla-inbound/rev/82e8d51e41a5
Part 2 - Remove the "progressmeter" element and related tests. r=bgrins,bzbarsky
https://hg.mozilla.org/mozilla-central/rev/0f64862fa1c3
https://hg.mozilla.org/mozilla-central/rev/82e8d51e41a5
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Depends on: 1510211
Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.