Open Bug 1507167 Opened 2 years ago Updated 10 months ago

mobile/android/components/extensions/test/mochitest/test_ext_tabs_create.html | Test timed out.

Categories

(GeckoView :: Extensions, defect, P5)

defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

Filed by: jwillcox [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=211572624&repo=try

https://queue.taskcluster.net/v1/task/Oj-lhEfeQTOf28RWs0gIAA/runs/0/artifacts/public/logs/live_backing.log

This and many other extension tests fail in automation under TestRunnerActivity.
Product: Firefox for Android → GeckoView

This test was disabled in bug 1525959. Let's re-enable it when possible.

Blocks: 1563277
No longer blocks: geckoview_mochitest
Depends on: 1539144

This is being addressed in bug 1562844.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1562844

Re-opening because the test is still disabled.

When I run the test with ./mach test mobile/android/components/extensions/test/mochitest/test_ext_tabs_create.html

then I see the following output in adb logcat :

09-17 13:29:46.360  7089  7104 E GeckoConsole: [JavaScript Error: "BrowserApp.selectTab is not a function" {file: "chrome://geckoview/content/ext-tabs.js" line: 416}]
09-17 13:29:46.360  7089  7104 E GeckoConsole: update@chrome://geckoview/content/ext-tabs.js:416:26
09-17 13:29:46.360  7089  7104 E GeckoConsole: call/result</<@resource://gre/modules/ExtensionParent.jsm:1156:68
09-17 13:29:46.360  7089  7104 E GeckoConsole: withPendingBrowser@resource://gre/modules/ExtensionParent.jsm:767:26
09-17 13:29:46.360  7089  7104 E GeckoConsole: call/result<@resource://gre/modules/ExtensionParent.jsm:1156:24
09-17 13:29:46.360  7089  7104 E GeckoConsole: callAndLog@resource://gre/modules/ExtensionParent.jsm:1115:14
09-17 13:29:46.360  7089  7104 E GeckoConsole: call@resource://gre/modules/ExtensionParent.jsm:1155:25

... and the test times out. This means that the test can only be re-enabled once the tabs API supports the tab.active property on GeckoView - i.e. bug 1565536

The test uses active here: https://searchfox.org/mozilla-central/rev/7ed8e2d3d1d7a1464ba42763a33fd2e60efcaedc/mobile/android/components/extensions/test/mochitest/test_ext_tabs_create.html#38

Depends on: 1565536
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: General → Extensions
You need to log in before you can comment on or make changes to this bug.