Closed Bug 1507699 Opened Last year Closed Last year

After Update Thunderbird 60.3.2 Mac Crash after attempt to edit adresses

Categories

(Thunderbird :: General, defect, critical)

defect
Not set
critical

Tracking

(thunderbird_esr60? affected)

RESOLVED FIXED
Thunderbird 65.0
Tracking Status
thunderbird_esr60 ? affected

People

(Reporter: mgehlen, Unassigned)

Details

(Keywords: crash, regression, regressionwindow-wanted)

Crash Data

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

MacOS 10.11.6
Microsoft Word for Mac


Update Thunderbird 60.3.2 Mac Crash after attempt to edit adresses

Follow up problem of Bug Fix 1506800 (and 1507177)
The corruption of doc. and docx. attachments is solved with Update 60.3.2.
But now Thunderbird crashes immediately, after double click in an adress to edit it. The editing feature does not start. In Thunderbird 60.3.1 this problem did not occur, only after the special update 60.3.2.  




Actual results:

Crash Report:

AdapterDeviceID: 0x0166
AdapterVendorID: 0x8086
Add-ons: de-DE%40dictionaries.addons.mozilla.org:2.0.6,en-US%40dictionaries.addons.mozilla.org:8.1,fr-dicollecte%40dictionaries.addons.mozilla.org:6.3,langpack-de%40thunderbird.mozilla.org:60.0buildid20180731173940,marcoagpinto%40mail.telepac.pt:2.66,tbthemefixed%40wanhunglo.com:64.6,%7B5e9999c2-ba1d-44b6-bcee-5b30ce37d3b0%7D:1.3.0,%7B3ed8cc52-86fc-4613-9026-c1ef969da4c3%7D:3.3.0,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:60.3.2
BuildID: 20181115145950
ContentSandboxCapable: 1
ContentSandboxLevel: 1
CrashTime: 1542355839
FramePoisonBase: 9223372036600930304
FramePoisonSize: 4096
InstallTime: 1542326661
Notes: AdapterVendorID: 0x8086, AdapterDeviceID: 0x0166FP(D00-L1100-W00000000-T010) WR? WR- OMTP? OMTP+3 GL Context? GL Context+ 
ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 520
StartupCrash: 0
StartupTime: 1542355328
TelemetryEnvironment: {"build":{"applicationId":"{3550f703-e582-4d05-9a08-453d09bdfdc6}","applicationName":"Thunderbird","architecture":"x86-64","buildId":"20181115145950","version":"60.3.2","vendor":null,"platformVersion":"60.3.0","xpcomAbi":"x86_64-gcc3","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":16384,"virtualMaxMB":null,"cpu":{"count":8,"cores":4,"vendor":"GenuineIntel","family":6,"model":58,"stepping":9,"l2cacheKB":256,"l3cacheKB":6144,"speedMHz":2300,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAES"]},"os":{"name":"Darwin","version":"15.6.0","locale":"de"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":null,"vendorID":"0x8086","deviceID":"0x0166","subsysID":null,"RAM":null,"driver":null,"driverVersion":null,"driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":1440,"screenHeight":900,"scale":2}],"features":{"compositor":"none","gpuProcess":{"status":"unused"}}},"appleModelId":"MacBookPro10,1"},"settings":{"blocklistEnabled":true,"e10sEnabled":false,"e10sMultiProcesses":4,"telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":false},"userPrefs":{"app.update.auto":false,"browser.cache.disk.capacity":358400,"browser.search.region":"EG","privacy.donottrackheader.enabled":true},"sandbox":{"effectiveContentProcessLevel":1},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{}}
ThreadIdNameMapping: 6:"Gecko_IOThread",7:"Socket Thread",8:"JS Watchdog",18:"BGReadURLs",19:"Hang Monitor",20:"Timer",22:"Cache2 I/O",23:"Cookie",24:"GMPThread",25:"Compositor",26:"VRListener",27:"ImgDecoder #1",28:"ImageIO",29:"IPDL Background",32:"LoadRoots",33:"DataStorage",34:"DataStorage",35:"mozStorage #1",42:"ImgDecoder #2",43:"ImgDecoder #3",44:"DOM Worker",45:"ImageBridgeChild",53:"SysProxySetting",54:"ProxyResolution",57:"DNS Resolver #1",58:"mozStorage #2",59:"mozStorage #3",60:"mozStorage #4",61:"DataStorage",62:"URL Classifier",63:"Classifier Update",64:"HTML5 Parser",65:"localStorage DB",69:"mozStorage #5",69:"StreamTrans #10",
Throttleable: 1
UptimeTS: 511.68393904
Vendor: 
Version: 60.3.2
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.



Expected results:

editing of adressbook should not be affected
Can you look under the Crash reports section. What we want is the crash id. (Those get auto linked in bugzilla if you put "bp-" before the id)
And as we said before, please type "Bug 1506800 and bug 1507177" and not "Bug Fix 1506800 (and 1507177)" :-(
Here the Crash Report ID: 71bcbeb1-bc1f-45d1-bb42-d5ee90181116
bp-1bcbeb1-bc1f-45d1-bb42-d5ee90181116
Crash Signature: [@ CoreFoundation@0xbde94 ]
All reports are on the "private" version 60.3.2 :-(

Zibi, it's crashing in OSPreferences::ReadDateTimePattern().
Flags: needinfo?(gandalf)
Severity: normal → critical
Keywords: crash
the problem persists

bp-f9259d31-8182-4d94-8112-5749d0181116
Flags: needinfo?(mgehlen)
works fine, no crash
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
How about this try build:
https://queue.taskcluster.net/v1/task/TqaFlPsDT8yrfPjSasaNuw/runs/0/artifacts/public/build/target.dmg

I backed out another change that was made between 60.3.1 and the unofficial 60.3.2. There were five changes made between these two versions, so this is trying to undo the second one of them.

Thanks for your help!
Flags: needinfo?(mgehlen)
I forgot to ask: What exactly causes the crash? Open the address book, double-click a contact, changes some fields, hit OK. Or does it depend on the fields? When does the crash happen? Or do you use CardBook, the add-on, for address management. Anything that can help reproduce the crash would be helpful. The two reports
bp-71bcbeb1-bc1f-45d1-bb42-d5ee90181116
bp-f9259d31-8182-4d94-8112-5749d0181116
have nothing in common although most of the other crashes
https://crash-stats.mozilla.com/signature/?signature=CoreFoundation%400xbde94&date=%3E%3D2018-11-09T19%3A49%3A28.000Z&date=%3C2018-11-16T19%3A49%3A28.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#reports
are in intl/locale/mac/OSPreferences_mac.cpp:163
this version also crashes
bp-61da9b95-1725-4ce5-9449-d0ba40181116
bp-4ef6fd22-266c-47e5-87d1-612990181116

Opening of the adress book is possible. double click a existing contact or click of "new contact" leads to immediate crash before even the window with the details of the contact opens. I don't use CardBook. 
"New list" and "write" are fine and functioning
Flags: needinfo?(mgehlen)
(In reply to Magnus Melin [:mkmelin] from comment #8)
> https://hg.mozilla.org/releases/mozilla-esr60/file/tip/intl/locale/mac/
> OSPreferences_mac.cpp#l163
> 
> Does formatter need to be null-checked?

Yep - it should be.

https://developer.apple.com/documentation/corefoundation/1396269-cfdateformattercreate?language=objc

I have no idea what changed to expose it.
Flags: needinfo?(gandalf)
Thanks for testing. This is absolutely puzzling. Nothing was changed in the way the panel for a new contact or the details of the existing contact is opened.

Richard, can you confirm the crashes with the try builds from comment #13 and comment #9. I can provide more builds with backouts, but is simply doesn't make sense to backout things which are in totally unrelated areas of the code. These are the differences between 60.3.1 and 60.3.2:
  Bug 1230815 - remove unused SetStripHtml() and accumulate HTML part to correct tag stripping, test. r=aceman a=jorgk
  Bug 1230815 - remove unused SetStripHtml() and accumulate HTML part to correct tag stripping. r=aceman a=jorgk
* Bug 32216 - If the 'Date' header is invalid, use date from 'Received' header instead. r+a=jorgk
  Bug 1504088 - Stop overflowing the toolbars in main window. r+a=jorgk
  Bug 1506800 - Don't sent AppleDouble for files with extension unless whitelisted. r=mkmelin a=jorgk
* Bug 1506422 - Replace use of nsMsgI18NFileSystemCharset() wit
We've already tried backing out the ones marked (*).

It wouldn't be caused by the CSS change in bug 1504088??
Zibi, can you add that null check in another bug please.
Flags: needinfo?(richard.marti)
Perhaps for the first attempt 5 hours ago, I send the wrong crash report. I did not realize the second window with "not send crash reports".
These should be the correct ones:
bp-063d8610-ef52-4c9e-bac4-f96d20181116
bp-17cdb399-5fe6-4a85-a2b1-6c97f0181116
I installed the first Test Version again. This is now definitvely the correct crash report of this version, whoch was posted 7 hours ago
bp-73e25d88-5f22-447f-bdcf-95af10181116
Filed bug 1507907 for the formatter null check.
(In reply to Jorg K (GMT+1) from comment #17)
> 
> Richard, can you confirm the crashes with the try builds from comment #13
> and comment #9.

No problem with both builds. Opening contacts and also create new ones without problems.

mgehlen, could you try them with all extensions disabled?
Flags: needinfo?(richard.marti)
Richard, I assume the unofficial 60.3.2 (bug 1506800 comment #27) also works, right?
Flags: needinfo?(richard.marti)
Yes, it works too for me.
Flags: needinfo?(richard.marti)
I tried the trial version (of 2 hours ago) in the safe mode with all extensions disabled.
Again crash
bp-8a690f5e-5b34-4efe-9cf7-2e3af0181116

I tried also the "private update" 60.3.2 from yesterday in the safe mode.
again crash
bp-95fa8641-00bf-4f5d-ba29-f44a30181116
How about this one:
https://queue.taskcluster.net/v1/task/RZAeNGJdRlm4TfdzBuiNdQ/runs/0/artifacts/public/build/target.dmg

That includes a fix to a potential crash in OSPreferences_mac.cpp as reported here:
bp-95fa8641-00bf-4f5d-ba29-f44a30181116
Flags: needinfo?(mgehlen)
Thanksa lot - I am travelling and away from my computer. I will be back wednesday evening and run the test then immediately.
Flags: needinfo?(mgehlen)
We hope this is fixed by bug 1507907. You won't get any regression window here since the crash suddenly popped up on some pre-release ESR 60.3.2 builds. But Richard can't reproduce the crash on the same builds.
This last target version works perfectly - thanks a lot for all your efforts
Fixed by bug 1507907. The reporter is happy, so I'm closing this. Expect the fix in an official version in 1-2 weeks.

Thanks a lot for hanging in there with us and testing many versions!
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
You need to log in before you can comment on or make changes to this bug.