Closed Bug 1507817 Opened 4 years ago Closed 9 months ago

Menus with wayland enabled missing shadows

Categories

(Core :: Widget: Gtk, defect, P2)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1738084
Tracking Status
firefox65 --- affected

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community)

Attachments

(4 files)

Attached image wayland.png
Noticed that in GNOME 3 and the "Yaru" (Ubuntu) theme, enabling Wayland causes borders around context menus to not appear. This makes the menu hard to see on white backgrounds. 

See screenshots.
Attached image xwayland.png
Blocks: wayland
This also applies to the normal Firefox menus in the menu bar as well.
Summary: Context menus with wayland enabled missing borders/shadow → Menus with wayland enabled missing borders/shadow
...but not the hamburger menu, at least using Yaru.
That's very interesting, thanks.
We may use a wrong window type on Wayland/popup as we did some magic here to place popus correctly.
When testing with Radiance theme, the popups is apparently missing shadows, but the border itself is here.

This is no longer an issue.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED

After upgrading from Ubuntu 18.10 to 19.04 the context menus now have borders but still do not have shadows. Adwaita and Yaru themes have very subtle shadows but they are more noticeable with Ambiance and Radiance.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Menus with wayland enabled missing borders/shadow → Menus with wayland enabled missing shadows

(In reply to Asif Youssuff from comment #7)

This is no longer an issue.

Which version are you referring to? I'm still not seeing any shadows under menus on 66.0.3 (Fedora 29) and 68 alpha (firefox-flatpak.mojefedora.cz).

Note: In my case (since a few months), the border is visible, but the shadow is not.

I started to use the Plata theme, and I see this issue on the latest nightly on Ubuntu Eoan. It is really obvious with this theme because there are no borders around the menus.

I see this using the Materia theme. Materia has the following section in gtk.css; which causes the bug.

#MozillaGtkWidget menu {
border: none;
}

This is probably there for the X11 version of Firefox. Please check if the other themes have a similar section.

(In reply to Berend De Schouwer from comment #12)

I see this using the Materia theme. Materia has the following section in gtk.css; which causes the bug.

#MozillaGtkWidget menu {
border: none;
}

This is probably there for the X11 version of Firefox. Please check if the other themes have a similar section.

At least with the default Gtk Adwaita theme, the border is present, but the shadow is not. See also my comment #9.

Blocks: wayland-popup
No longer blocks: wayland

Looks like X11 Firefox is also missing the shadows....can you confirm?
Thanks.

Flags: needinfo?(yoasif)
Flags: needinfo?(yoasif)

Martin, I used the Materia theme (mentioned in comment 12) and confirmed that the Xorg session shows a shadow, while the Wayland session does not. I am not able to confirm your observation.

Priority: -- → P2

IMHO the shadow itself is painted as a part of window but I was referring to additional border shaping - for instance Adwaita has rounded corners on popup windows and we don't paint that on both X11 and Wayland.

We may be able to produce default window shadows on Wayland too.

I think bug 1708136 is related here.

See Also: → 1708136

(In reply to Martin Stránský [:stransky] (ni? me) from comment #17)

IMHO the shadow itself is painted as a part of window but I was referring to additional border shaping - for instance Adwaita has rounded corners on popup windows and we don't paint that on both X11 and Wayland.

We may be able to produce default window shadows on Wayland too.

I had previously filed the rounding thing to bug 1560482.

Like bug 1708136 this should work in latest nightly. Please reopen if it doesn't for you.

Status: REOPENED → RESOLVED
Closed: 4 years ago9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1708136
Duplicate of bug: 1738084
You need to log in before you can comment on or make changes to this bug.