Closed Bug 150925 Opened 22 years ago Closed 22 years ago

Cannot change e-mail address for bugzilla account.


(Bugzilla :: User Accounts, defect)

Windows 98
Not set



Bugzilla 2.16


(Reporter: 6jju4k002, Assigned: myk)





(1 file)

URL of bugzilla

In the account settings tab,
Cannot chage e-mail address for bugzilla account.

I am trying to change e-mail address of account (Not this account)
I cannot do so.
I continuously get the following error message.
“Email change already in progress; please check your email.”
After one and a half hours, I have not seen any e-mail in my in-tray.

I am receiving mails, including the one to set up this accunt.
In the mean time, I have sucessfully changed the password, and I can still log
on/off on my old e-mail address.

The mozilla account I’m submitting this bug from is neither the
Account adentified by the old e-mail address, nor that defined by the new e-mail
*** Bug 150933 has been marked as a duplicate of this bug. ***
*** Bug 150992 has been marked as a duplicate of this bug. ***
What email address are you trying to change from/to? You should have got email
to both your old and your new accounts.
*** Bug 150957 has been marked as a duplicate of this bug. ***
-> 2.16 until we see if this is a bmo specific thing, or if its present in CVS
Summary: Cannot chage e-mail address for bugzilla account. → Cannot change e-mail address for bugzilla account.
Target Milestone: --- → Bugzilla 2.16
I am trying to change my e-mail to:
The e-mail address I'm changing from I will only give out by e-mail.
This is because was attempting to change addresses to avoid spam.

I have had no e-mails pertaining to e-mail address changes.
On either the "from" or the "to" accounts. 
myk hs disabled this feature for the moment, because of the issues involved.
this should block bug 150783
Its not a regression, since it didn't work before the upgrade
So, this works for me (locally, not on bmo). myk, have you made local changes to
useprefs.cgi/ which would break this?
I'm running tip on Syndicomm again and I can't get this to not work there,
either...  or on landfill/bugzilla-2.16-branch.  Seems to work fine in both of
those places.

With regard to Bugzilla I think this is a "WORKSFORME"...  should we move this
to the product since it's obviously something specific to b.m.o?  
Possibly. I didn't think any of myk's changes touched this part of bugzilla, though.

myk: HAve you got any ideas?
I haven't done anything that I think might cause this problem.  I made no
changes to, and I made only trivial changes to userprefs.cgi:

mothra:bugzilla> cvs diff -u userprefs.cgi
Index: userprefs.cgi
RCS file: /cvsroot/mozilla/webtools/bugzilla/userprefs.cgi,v
retrieving revision 1.35
diff -u -r1.35 userprefs.cgi
--- userprefs.cgi       7 May 2002 21:28:42 -0000       1.35
+++ userprefs.cgi       24 Jun 2002 18:11:01 -0000
@@ -45,7 +45,7 @@

 my @roles = ("Owner", "Reporter", "QAcontact", "CClist", "Voter");
 my @reasons = ("Removeme", "Comments", "Attachments", "Status", "Resolved",
-               "Keywords", "CC", "Other");
+               "Keywords", "CC", "Other", "Unconfirmed");

 foreach my $role (@roles) {
     foreach my $reason (@reasons) {

Once I re-upgrade to catch regression fixes this week I'll look into this in
more detail and possibly turn it back on to see if testing can determine the
cause of the problem.
On 6/24 (comment 13) Myk said he was going to upgrade bmo again "this week". 
Has that happened yet?  Do we know anything else here yet?
Nope, I haven't upgraded yet; I'll do so today or tomorrow.
ok, "tomorrow" would have been 7/2.  My calendar says it's 7/4 now (well, it
will be in Mountain View in about 15 minutes ;)   Status?  (you can tell I'm
itching to get 2.16 out, can't you? ;)
I set up a test installation today that was upgraded to the tip, but I took it
back down because I probably won't have time tomorrow to intervene if something
goes horribly wrong, so the next opportunity for this to happen is Friday.
*** Bug 150889 has been marked as a duplicate of this bug. ***
I set up a test installation at the following URL:

On this installation I enabled email address changes.  I then tried to change
the email address for one of my accounts, and it worked: I submitted the change
request, received both email messages, confirmed the change via the link in the
message sent to the new address, and my email address was changed.

Reporter, can you try to change your address again using the test installation
and report your results?

Myk, I was the reporter on a duplicate of this bug.  I am still unable to change
my email address on the test bugzilla.  I get exactly the same
error as before ("Error   Email change already in progress; please check your
email. [...]"), and I still don't get an email.
So I have no idea what's going on.  If for some reason you need to check your
logs on the server, I just did it around 13:39 PDT 6 JUL 2002.
Any ideas?  Do you suppose it has something to do with various user level
permissions (of which I have no special ones, and you probably have all the good
ones)?  Don't know why it would, but whatever.
I got the same error message on mothra that I did on b.m.o.
Strange, neither account has email change tokens (or any other tokens), so
HasEmailChangeToken appears to be failing somehow.  Perhaps the $userid variable
isn't set correctly?
The problem is the following SQL statement, used to determine whether or not
the user already has an email change token:

SELECT token FROM tokens WHERE userid = [userid] AND tokentype = 'emailnew' OR
tokentype = 'emailold' LIMIT 1

MySQL interprets the statement like this and grabs the first email change token
it finds:

SELECT token FROM tokens WHERE (userid = [userid] AND tokentype = 'emailnew')
OR tokentype = 'emailold' LIMIT 1

Adding parentheses fixes the problem:

SELECT token FROM tokens WHERE userid = [userid] AND (tokentype = 'emailnew' OR
tokentype = 'emailold') LIMIT 1

The patch has been applied to the mothra test installation.  Reporters, try
changing your email addresses again and report back.
This worked for me.  I was able to successfully change the e-mail address.  In
addition, I was able to cancel the change from either e-mail address.
It worked!  I can finally stop checking that old address.  Good job, Myk.
Yeah, seems to work for me, too, thanks Myk.
Comment on attachment 90513 [details] [diff] [review]
patch v1: should fix problem

doh. Why couldn't any of us reproduce it?

r=bbaetz x2
Attachment #90513 - Flags: review+
Checking in;
/cvsroot/mozilla/webtools/bugzilla/,v  <--
new revision:; previous revision: 1.12

Checking in;
/cvsroot/mozilla/webtools/bugzilla/,v  <--
new revision: 1.13; previous revision: 1.12
Closed: 22 years ago
Resolution: --- → FIXED
Hmm I have the same problem. I don't get any emails and now I have three days to
wait to try ist again. Very annyoing :(
QA Contact: matty_is_a_geek → default-qa
Where on is the UI page to change my email address? I.e., without using SQL, tokens, or other backend stuff.
Click on the user icon in the top right corner, should give you a drop down menu.  Pick Preferences from the menu.  The email change is at the bottom of the Account tab (which should be the default one shown to you.
No such link when viewed thru Chrome

I did see this OK on my iPhone and changed my email address there, apparently successfully, but was required to log in under the old email address when I came back here to send a schreenshot of the browser window (chrome). Alas, no such ability.
Update - was able to confirm the submission I had submitted on my iphone, but no functionality seen when viewed through desktop (Chrome).
Nothing yet. I cannot change my email address.
Deleting my account, then.

This bug appears still not solved.
I least I cannot find anywhere an option to change the email address.

How is one supposed to do this, without deleting and re-adding an account, in which way all context would be lost?

Meanwhile I did find how to change the email address.

there is a field that is easy to overlook: "New email address:"

The option to change the email address should be made more prominent.

You need to log in before you can comment on or make changes to this bug.