request queue page shows 'Bugzilla::User=HASH(...)' instead of username

RESOLVED FIXED

Status

()

defect
P2
normal
RESOLVED FIXED
5 months ago
14 days ago

People

(Reporter: dbaron, Assigned: kohei)

Tracking

(Regression, {regression})

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Sometime in the past month or two, the heading near the top of the page:

https://bugzilla.mozilla.org/request.cgi?action=queue&requester=&product=&type=all&requestee=dbaron%40dbaron.org&component=&group=requester&do_union=0

has regressed to showing the form:

Requester: Bugzilla::User=HASH(0x13e228b8)

whereas it used to show some form (I forget exactly what form) like:

Requester: David Baron :dbaron: ...

(maybe including the email address).

On bugzilla.mozilla.org, I believe this has regressed within the past month or two, but not as recently as within the past week.
I'm guessing this regressed in bug 1508903 or bug 1480042. Should be easy to fix.
Assignee: attach-and-request → dylan
Component: Attachments & Requests → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
Status: NEW → ASSIGNED
Assignee: dylan → imadueme
Priority: -- → P2

This is actually my bug. I’ll fix it…

Assignee: imadueme → kohei.yoshino

Merged to master.

Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
No longer blocks: 1480042
Regressed by: 1480042
You need to log in before you can comment on or make changes to this bug.