Closed Bug 1514652 Opened 11 months ago Closed 11 months ago

in-content sanitize sub-dialog buttons are truncated, if Open Windows10 Settings > Ease of access > Display > Make text bigger 125%

Categories

(Firefox :: Preferences, defect, P1)

65 Branch
Unspecified
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 + verified
firefox66 + verified

People

(Reporter: alice0775, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached image screenshot 64 vs 65 (obsolete) —
[Tracking Requested - why for this release]:broken ui die to new theme.

See attached screenshot

STR
1. Open about:preferences#privacy
2. Click on [Clear History...] button

3. If time range is not "Everything", perform the following steps
4. Select "Everything" and click on [Clear Now]
5. Click on [Clear History...] button again

Actual results:
buttons are truncated
Attached image screenshot 64 vs 65
Attachment #9031784 - Attachment is obsolete: true
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d3dd7815054436f548a7e3c545c5de47c110d4d9&tochange=75905c21f4164c4cedbfc83aa6dd8e153105f000

Regressed by: 75905c21f416	Qinghao_Jack_Song — Bug 1498444 - Migrate Sanitize Dialogs to use Fluent for localization r=Gijs,flod,zbraniecki

Qinghao Song,
Your patch seems to cause the regression. Can you please look into this?
Blocks: 1498444
Flags: needinfo?(songqing)
Summary: in-content sub-dialog buttons are truncated → in-content sanitize sub-dialog buttons are truncated
Summary: in-content sanitize sub-dialog buttons are truncated → in-content sanitize sub-dialog buttons are truncated, if Open Windows10 Settings > Ease of access > Display > Make text bigger 125%
This seems to be due to the async-ness of the translations. A bit similar to bug 1500440, but more severe because it impedes actual functionality and is in more common use than about:profiles .

We should be able to use the mechanism from bug 1457252 here.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P1
Flags: needinfo?(songqing)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/40332638e058
deal with async translations and their sizing in the sanitize dialog, r=zbraniecki
https://hg.mozilla.org/mozilla-central/rev/40332638e058
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Please request Beta approval on this when you get a chance.
Flags: qe-verify+
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> Please request Beta approval on this when you get a chance.

Yes, I want to be sure this is fixed, though - it's basically race conditions + font sizes, which is a fun combination. Alice, could you please confirm if this is fixed in latest nightly?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(alice0775)
(In reply to :Gijs (he/him) from comment #8)
> (In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> > Please request Beta approval on this when you get a chance.
> 
> Yes, I want to be sure this is fixed, though - it's basically race
> conditions + font sizes, which is a fun combination. Alice, could you please
> confirm if this is fixed in latest nightly?


I confirmed that the the latest Nightly66.0a1(Build ID 20181219220049) fixed the issue.
Flags: needinfo?(alice0775)
(In reply to Alice0775 White from comment #9)
> (In reply to :Gijs (he/him) from comment #8)
> > (In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> > > Please request Beta approval on this when you get a chance.
> > 
> > Yes, I want to be sure this is fixed, though - it's basically race
> > conditions + font sizes, which is a fun combination. Alice, could you please
> > confirm if this is fixed in latest nightly?
> 
> 
> I confirmed that the the latest Nightly66.0a1(Build ID 20181219220049) fixed
> the issue.

Thank you!
Status: RESOLVED → VERIFIED
Comment on attachment 9032164 [details]
Bug 1514652 - deal with async translations and their sizing in the sanitize dialog, r?zbraniecki

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1498444

User impact if declined: "Clear recent history" dialog can be cut off in the preferences at certain font sizes

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment #0

List of other uplifts needed: n/a

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Fairly straightforward fix specific to this dialog that deals with ensuring we take the size of the new string into account

String changes made/needed: n/a
Attachment #9032164 - Flags: approval-mozilla-beta?
Comment on attachment 9032164 [details]
Bug 1514652 - deal with async translations and their sizing in the sanitize dialog, r?zbraniecki

[Triage Comment]
Fix for cut-off "Clear recent history" dialog at certain font sizes. Approved for 65.0b6.
Attachment #9032164 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified Fixed on latest Firefox beta 65.0b6 (64-bit) on Windows 10.
Flags: qe-verify+
[Tracking Requested - why for this release]:removed by mistake

My mistake, thought I had the right build, it seemed straight forward issue and it seemed fixed on my win10/65.b6 ;
resetting the flags
Verified Fixed on latest Firefox beta 65.0b6 (64-bit) on Windows 10.
See Also: → 1523696
Depends on: 1526379
You need to log in before you can comment on or make changes to this bug.