Clear Recent History dialog is too small, hiding options

RESOLVED FIXED in Firefox 65

Status

()

P1
normal
RESOLVED FIXED
2 months ago
16 days ago

People

(Reporter: postmaster, Assigned: jaws, Mentored, NeedInfo)

Tracking

({regression})

66 Branch
mozilla67
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 65+, firefox-esr60 unaffected, firefox65+ fixed, firefox66+ fixed, firefox67+ fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

2 months ago
Posted file clear_history_dialog_issue.zip (obsolete) —

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Icon "Show your history" -> option "Clear Recent History...":

Opened modal dialog "Clear All History" is incorrectly resized hiding an area below section "Data" including buttons "Clear Now" and "Cancel", see attached file "clear_history_dialog_issue.png", another attachment "clear_history_dialog.png" is a dialog of the correct size.

Actual results:

That issue happened randomly usually on the first click, second click opens a dialog of the correct size.

Tested on Firefox Developer Edition 66.0b2.

Comment 1

2 months ago

Triaging to General because of bug 1351428, comment 2. I would've thought this belongs in Toolkit :: Data Sanitization but apparently not.

Component: Untriaged → General

Updated

2 months ago
See Also: → bug 1524754

Updated

a month ago
See Also: bug 1524754
Duplicate of this bug: 1524754

Updated

a month ago
Duplicate of this bug: 1525236

Comment 4

a month ago

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
20190124174741

I managed to reproduce this once after I don't know how many attempts. I tried another 15 times but the dialog was a normal size.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Summary: "Clear Recent History..." modal dialog issue → Clear Recent History dialog is too small, hiding options

Updated

a month ago
Duplicate of this bug: 1525377

Comment 6

a month ago

:adw this has collected some duplicates. Since you fixed bug 495452, maybe you'd be interested in taking a look, or know someone who is.

Flags: needinfo?(adw)

Comment 7

a month ago

A similar bug was happened a few days ago.
https://bugzilla.mozilla.org/show_bug.cgi?id=1518786

I'm not able to look at this right now, and I'm not sure who worked on this last. It may have been a while since anyone has. I'll add myself to the bug as the mentor though in case a contributor is interested in fixing it.

Mentor: adw
Flags: needinfo?(adw)

Like bug 1518786, this seems like a regression from bug 1498444 though I didn't confirm.

Blocks: 1498444
status-firefox65: --- → affected
status-firefox66: --- → affected
status-firefox67: --- → affected
Component: General → Preferences
Flags: needinfo?(jaws)
Keywords: regression

Comment 10

a month ago

This dialog isn't part of preferences, see screenshot in the zipfile which shows a native win7 dialog.

It can also be opened from preferences, and we fixed that version in bug 1514652.

I guess we need to call sizeToContent() in the non-preferences case. Jared, does that seem right?

Component: Preferences → Bookmarks & History
See Also: → bug 1514652

Yeah, I'll take this.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)

(In reply to :Gijs (he/him) from comment #10)

This dialog isn't part of preferences, see screenshot in the zipfile which shows a native win7 dialog.

I know… I was following the component of bug 1498444 which regressed this though.

It can also be opened from preferences, and we fixed that version in bug 1514652.

I guess we need to call sizeToContent() in the non-preferences case. Jared, does that seem right?

Comment 13

a month ago

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #12)

I was following the component of bug 1498444 which regressed this

So now this is in Bookmarks & History though Marco Bonardo said it doesn't belong here, as I initially mentioned in comment 1.

¯_(ツ)_/¯ => Back to general (the Clear Recent History dialog doesn't actually have a home)

Component: Bookmarks & History → General

If we're okay with a toolkit component despite this being a browser thing I'll adopt it into Data Sanitization.

Component: General → Data Sanitization
Priority: -- → P1
Product: Firefox → Toolkit

Updated

a month ago
Duplicate of this bug: 1525899

Comment 20

a month ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1feee32f9793
Wait until the style attribute is applied to the dialog before sizing it. r=Gijs

Comment 21

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
status-firefox67: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment 22

a month ago
Posted image dialog.png

Still problem a little.
Lack of right side of the dialog.
Nightly 67.0a1 (2019-02-08)
build id: 20190208095514
Language: ja

Comment 23

a month ago

(In reply to Walter Labonte from comment #22)

Created attachment 9042528 [details]
dialog.png

Still problem a little.
Lack of right side of the dialog.
Nightly 67.0a1 (2019-02-08)
build id: 20190208095514
Language: ja

This is inside the preferences again... was this a problem on the previous nightly as well?

Either way, this probably wants to be a new bug - could you file one please?

Flags: needinfo?(nolamiller1203+bugzilla)

Comment 24

a month ago

I posted it as a new bug report.
https://bugzilla.mozilla.org/show_bug.cgi?id=1526379

And i don't know that it was happened on the previous nightly.

Flags: needinfo?(nolamiller1203+bugzilla)

Updated

a month ago
Depends on: 1526379
status-firefox-esr60: --- → unaffected
tracking-firefox65: --- → +
tracking-firefox66: --- → +
tracking-firefox67: --- → +
Flags: qe-verify+

Comment on attachment 9042239 [details]
Bug 1523696 - Wait until the style attribute is applied to the dialog before sizing it. r?Gijs

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1498444

User impact if declined

The Clear Recent History dialog may be sized too small for users to actually click the button to clear their history.

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

(requesting QE verification since this just landed on m-c and uplift request is for release)
0. Make sure you are using a temporary profile or one you are OK with losing history

  1. Go to about:config and set layout.css.devPixelsPerPx to 2.5 or 1.25 if 2.5 is too big
  2. Open the Clear Recent History dialog by pressing Ctrl+Shift+Del on Windows, Cmd+Shift+Del on MacOS
  3. Change the selected timespan to Everything
  4. Press the "Clear Now" button
  5. Reopen the dialog, look for any parts being cut off otherwise choose "Last Hour"
  6. Press the "Clear Now" button
    (repeat steps 3-6 multiple times if not reproduced on the first step)

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Waits for localization to complete then uses the sizeToContent method to make sure the dialog is large enough for its content. The change is localized and only affects the Clear Recent History dialog.

String changes made/needed

none

Attachment #9042239 - Flags: approval-mozilla-release?
Attachment #9042239 - Flags: approval-mozilla-beta?

Comment on attachment 9042239 [details]
Bug 1523696 - Wait until the style attribute is applied to the dialog before sizing it. r?Gijs

[Triage Comment]
Avoid improperly-sized dialog boxes in some situations. Approved for 66.0b7 and 65.0.1.

Attachment #9042239 - Flags: approval-mozilla-release?
Attachment #9042239 - Flags: approval-mozilla-release+
Attachment #9042239 - Flags: approval-mozilla-beta?
Attachment #9042239 - Flags: approval-mozilla-beta+

Comment 27

a month ago
bugherderuplift
status-firefox65: affected → fixed
relnote-firefox: --- → 65+

Comment 28

a month ago
bugherderuplift
status-firefox66: affected → fixed
Comment hidden (me-too)
Whiteboard: [qa-triaged]

I've tested on Windows 7 x64, Windows 7 x86, Windows 10 x64 using Firefox 65.0, Firefox Developer Edition 66.0b2. I tried multiple times (~50 times), but I wasn't able even once to reproduce the issue, therefore I can't consider the verification reliable from my side.

Could you please help us to confirm this fix on Firefox 66 Beta 6 and latest Nightly 67.0a1?

Flags: qe-verify+ → needinfo?(postmaster)

Updated

a month ago
Duplicate of this bug: 1526991

Updated

16 days ago
See Also: → bug 1532188
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.