Re-style all markdown content, consistently

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 months ago
14 days ago

People

(Reporter: bzbarsky, Assigned: imadueme)

Tracking

(Depends on 1 bug)

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

Steps to reproduce:

  1. Load https://bugzilla.mozilla.org/enter_bug.cgi?product=Core

  2. Type

    '''
    Where are my letter bottoms?
    '''

but with backticks instead of single quotes.

  1. Click "Preview"

EXPECTED RESULTS: I can see the bottoms of the letters.

ACTUAL RESULTS: Nope.

DETAILS:

.bz_comment_text span.quote, .bz_comment_text span.quote_wrapped, div.bz_comment_text pre {
    background: #eee !important;
    color: #444 !important;
    display: block !important;
    margin-top: 5px !important;
    margin-bottom: -10px !important;
    overflow: auto;
    padding: 5px !important;
}

that "-10px" bottom margin forces things to be cut off.

(Reporter)

Updated

3 months ago
Summary: Preview cuts of bottoms of things using ``` → Preview cuts off bottoms of things using ```

And preview once the bug has been filed does not have this problem, at least on this bug.

Group: bmo-infra
Assignee: nobody → dylan

Updated

3 months ago
Blocks: bmo-markdown
Posted file GitHub Pull Request (obsolete) —
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED

That doesn't fix this issue.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Boris,

Are you saying you don't see the fix in production, or that the patch, when you test, it doesn't fix the issue?

Remember that FIXED is merged to release, and we release weekly.

Flags: needinfo?(bzbarsky)

I don't a behavior change in production, and Dylan on IRC was sounding like this fix has been deployed.

If this is not deployed, is there a test instance where the updated code is running where I could test behavior?

Flags: needinfo?(bzbarsky)

Okay, just discussed with Dylan and understand that the bug is not completely fixed, because it's still happening on the new bug page.

Summary: Preview cuts off bottoms of things using ``` → Enter bug page has different CSS styles applied to comment preview than show-bug
No longer blocks: bmo-markdown
Depends on: bmo-markdown
Posted file GitHub Pull Request (obsolete) —

A WIP still, but this greatly improves the styling of everything, including bumping the sizes of headings down a bit.

Attachment #9035049 - Attachment is obsolete: true
Summary: Enter bug page has different CSS styles applied to comment preview than show-bug → Re-style all markdown content, consistently
Assignee: dylan → imadueme
Attachment #9035848 - Attachment is obsolete: true
Status: REOPENED → RESOLVED
Last Resolved: 3 months ago3 months ago
Resolution: --- → FIXED
No longer blocks: 1522155
Regressions: 1522155
You need to log in before you can comment on or make changes to this bug.