Closed Bug 1521175 Opened 4 years ago Closed 3 years ago

[WebRender] Firefox reopened after an update has all the content shifted

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1489463
Tracking Status
firefox66 --- disabled
firefox67 --- disabled
firefox68 --- disabled
firefox69 --- disabled

People

(Reporter: kvark, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

Attached file about-support.txt

I've just updated to "66.0a1 (2019-01-17) (64-bit)". When Firefox restarted, it no longer occupied the full screen visually. However, mouse input was still processed as if it was occupying the full screen. See the screenshot attached, where Firefox thinks I'm hovering the mouse over the "Close" button.

Note that there is an external monitor attached that is placed virtually above the main one, where Firefox is supposed to be running.

Pushing over to Graphics for first diagnosis especially as the mouse input was in a different place to where Firefox was drawn.

Component: General → Graphics
Product: Firefox → Core

I'm experiencing the mouse shift with webrender on since bug 1490344 landed.

I'll look at it.

Assignee: nobody → stransky
Component: Graphics → Widget: Gtk

Is that webrender only or do you also see that without HW acceleration?

Flags: needinfo?(dmalyshau)

With tabs in titlebar this is nothing new to me on WebRender/KDE/Debian Testing.

On second thought, my issue is not the same as described in this bug.
I experienced the "half screen" issue prior to bug 1490344.

I will open a new bug.

Looks like this is only happening with WebRender for me

Flags: needinfo?(dmalyshau)

Bug 1523721 opened about the mouse cursor issue.

Hm, I'm unable to repoduce on Fedora 29 / gnome-shell with single monitor setup. I'll try reproduce that with more monitors. Also which system do you run? Thanks.

Flags: needinfo?(dmalyshau)

The issue appears fixed in 67.0a1 (2019-01-29) (64-bit). I can no longer reproduce it myself.

Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dmalyshau)
Resolution: --- → FIXED

Reopening as it still happens with nightly.

In a single-monitor setup, Firefox appears to start full-screen, then the window appears to resize, and take up a quarter of the screen, but mouse events behave as if it's fullscreen (e.g. moving the mouse over the top of the screen, where the firefox window isn't drawn, highlights tabs drawn in the quarter-size window).

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Yes, this appears to still be happening for me as well, regardless of the second screen...
Martin, you can find the info about my machine/environment in https://bugzilla.mozilla.org/attachment.cgi?id=9037654

This might be related to bug 1471094 which is also a shift of window after update.

Blocks: wr-linux
Summary: Firefox reopened after an update has all the content shifted → [WebRender] Firefox reopened after an update has all the content shifted
Duplicate of this bug: 1525233
Assignee: stransky → nobody
Priority: -- → P3
See Also: → 1502519

(Kestrel from bug 1489463 comment 12)

Results vary with the compositor, the undersized rendered window is top left and clickable for Basic compositor and bottom left with offset click zones for OpenGL/WebRender. The rest of the screen can be rendered as a maximized window (X11), black (Basic on XWayland), transparent (WebRender on XWayland) or white (Wayland).

Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1489463
You need to log in before you can comment on or make changes to this bug.