Closed Bug 1521194 Opened 9 months ago Closed 9 months ago

Disable Credit Card Autofill by default so we dogfood/test what we ship

Categories

(Toolkit :: Form Autofill, defect, P2)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox66 + fixed
firefox67 --- fixed

People

(Reporter: MattN, Assigned: MattN)

References

(Depends on 1 open bug)

Details

Attachments

(4 files)

We aren't currently working on pushing credit card autofill over the finish line so we should disable it by default so that we're testing and dogfooding what we ship to users.

There are two parts to this:

  1. Disable it by default in Nightly for users.[1]
  2. Disable the pref while running address autofill tests (probably easiest to move credit card tests to their own directory).[2]
    ** This ensures that we would catch regressions like bug 1520224 in automation.

[1] https://dxr.mozilla.org/mozilla-central/rev/c2593a3058afdfeaac5c990e18794ee8257afe99/browser/app/profile/firefox.js#1695
[2] https://dxr.mozilla.org/mozilla-central/search?q=extensions.formautofill.creditCards.available+true+path%3Atest&redirect=false

Flags: qe-verify+
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

Joni, can you update SUMO to remove mentions of credit card support? Thanks

Flags: needinfo?(jsavage)

That way the non-CC tests get run with credit card autofill unavailable which tests what we ship.

Depends on D18015

That way the non-CC tests get run with credit card autofill unavailable which tests what we ship.

Depends on D18016

Bug 1470184 unconditionally referenced credit cards even though credit card autofill was disabled for non-Nightly.

Depends on D18017

Comment on attachment 9039989 [details]
Bug 1521194 - Remove reference to credit cards from autofill description. r=jaws

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1470184

User impact if declined

Users will see a mention of credit card autofill in preferences even though that feature hasn't shipped.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Simply deleting the newly added element with the incorrect text.

String changes made/needed

String deletion. I asked @flod on Phabricator if the deletion is fine. Otherwise I can make a new commit with that one file reverted.

Attachment #9039989 - Flags: approval-mozilla-beta?

I think this should be OK. flod, can you confirm?

Flags: needinfo?(francesco.lodolo)

Yep, no need for a special beta patch this early in the cycle.

Flags: needinfo?(francesco.lodolo)

Just to clarify, only attachment 9039989 [details] (243ebbbec1cd) is to be uplifted since credit card autofill is already disabled on non-Nightly.

Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/e7a5e9d8567d
Disable Credit Card Autofill by default so we dogfood/test what we ship. r=jaws
https://hg.mozilla.org/integration/autoland/rev/f9854a74ac45
Move credit card autofill b-c tests to their own directory. r=jaws
https://hg.mozilla.org/integration/autoland/rev/0aa62e20675e
Move credit card autofill mochitest-plain tests to their own directory. r=jaws
https://hg.mozilla.org/integration/autoland/rev/243ebbbec1cd
Remove reference to credit cards from autofill description. r=jaws

Comment on attachment 9039989 [details]
Bug 1521194 - Remove reference to credit cards from autofill description. r=jaws

Remove reference to cc autofill since it won't be shipping in 66.
This should land for Monday's beta 5 build.

Attachment #9039989 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Based on comment 7 I am removing the qe-verify+ flag.

In case manual QA verification is needed for this bug fix then please set the qe verfy flag back to qe+ and provide the steps to reproduce. Thanks!

Flags: qe-verify+

I've removed mentions of credit cards. Thanks for the heads up.

Flags: needinfo?(jsavage)
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.