Port bug 1241885: Total MozMill faiure on 2019-01-19 on Linux only

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: jorgk, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 months ago

All Z's a orange, it looks like about all MozMill tests have failed.

https://taskcluster-artifacts.net/G5o2TzmdQ4aH9pXVHALfhg/0/public/logs/live_backing.log

EXCEPTION: Added Task did not appear
EXCEPTION: Expression "[0]" returned null. Anonymous == false
EXCEPTION: Expression "{"flex":"1"}" returned null. Anonymous == false
EXCEPTION: Timed out waiting for window open!
EXCEPTION: Timeout exceeded for waitForElement Lookup: /id("messengerWindow")/id("tabmail-container")/id("tabmail")/id("tabmail-tabbox")/id("tabpanelcontainer")/id("calendarTabPanel")/id("calendarContent")/id("calendarDisplayDeck")/id("calendar-view-box")/id("view-deck")/id("day-view")/anon({"anonid":"mainbox"})/anon({"anonid":"scrollbox"})/anon({"anonid":"daybox"})/[0]/anon({"anonid":"boxstack"})/anon({"anonid":"bgbox"})/[8]/
EXCEPTION: Timeout happened before event 'monthchange' was fired.
EXCEPTION: Timeout waiting for modal dialog to open.
EXCEPTION: Timeout waiting for the content tab to open
EXCEPTION: You need to specify a tab!
EXCEPTION: folder is undefined
EXCEPTION: folderA is undefined
EXCEPTION: mc.folderDisplay is null
EXCEPTION: nextTab is undefined
EXCEPTION: parent.messengerBundle is null
EXCEPTION: swc is null
EXCEPTION: this._rowMap is null
EXCEPTION: this.tabmail is undefined
EXCEPTION: waitFor: Timeout exceeded for '() => eid("day-view").getNode().orient == "horizontal"'

JavaScript error: chrome://messenger/content/accountUtils.js, line 357: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgMailSession.topmostMsgWindow]
JavaScript error: chrome://messenger/content/mailWindowOverlay.js, line 124: TypeError: gFolderDisplay is null

Looks like something is wrong with tabmail.

M-C last good: 3aa256c255f664c500714c34a3b9e353e5
M-C first bad: 57dc8bbbc38f79ce532feb8947b40311e9
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3aa256c255f664c500714c34a3b9e353e5&tochange=57dc8bbbc38f79ce532feb8947b40311e9

(Reporter)

Updated

3 months ago
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
Version: 65 → Trunk
(Reporter)

Updated

3 months ago
Keywords: leave-open
(Reporter)

Comment 1

3 months ago

Wow, Mac opt is 100% green and Windows hasn't even run yet. So we're looking for a Linux issue here. So this?
5433228bc018 Tim Nguyen — Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=dao,bzbarsky,stransky

Summary: Total MozMill faiure on 2019-01-19 → Total MozMill faiure on 2019-01-19 on Linux only
(Reporter)

Comment 2

3 months ago
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
(Reporter)

Comment 3

3 months ago

Richard, there might be more porting necessary. I'll port one hunk now and get it landed. Can you please take a look at the rest.

Flags: needinfo?(richard.marti)
(Reporter)

Updated

3 months ago
Summary: Total MozMill faiure on 2019-01-19 on Linux only → Port bug 1241885: Total MozMill faiure on 2019-01-19 on Linux only
(Reporter)

Updated

3 months ago
Attachment #9037738 - Flags: review?(mkmelin+mozilla)
Attachment #9037738 - Flags: review?(acelists)

Comment 5

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e1982e53702a
Port bug 1241885: Remove reference to WindowDraggingUtils.jsm. rs=bustage-fix DONTBUILD
(Reporter)

Comment 7

3 months ago

Culling some more. I think the entire binding can go, but I won't touch the CSS.

Attachment #9037739 - Flags: review?(mkmelin+mozilla)
Attachment #9037739 - Flags: review?(acelists)

Comment 8

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c79237b13f9a
Port bug 1241885: Remove reference to WindowDraggingUtils.jsm, take 2. rs=bustage-fix DONTBUILD
(Assignee)

Comment 9

3 months ago

You'd better used bug 1521213 which was for this.

Flags: needinfo?(richard.marti)
(Reporter)

Comment 10

3 months ago

Well, next time you CC me.

(Reporter)

Updated

3 months ago
Duplicate of this bug: 1521213
(Reporter)

Updated

3 months ago
Keywords: leave-open
(Reporter)

Comment 12

3 months ago
Comment on attachment 9037738 [details] [diff] [review]
1521277-remove-WindowDraggingUtils.patch

OK, Richard had the same patch, so it must be good.
Attachment #9037738 - Flags: review?(mkmelin+mozilla)
Attachment #9037738 - Flags: review?(acelists)
Attachment #9037738 - Flags: review+
(Reporter)

Updated

3 months ago
Attachment #9037739 - Flags: review?(mkmelin+mozilla)
Attachment #9037739 - Flags: review?(acelists)
Attachment #9037739 - Flags: review+
(Reporter)

Comment 13

3 months ago

Richard's patch from bug 1521213.

Attachment #9037741 - Flags: review+
(Reporter)

Updated

3 months ago
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED

Comment 14

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e50aae192485
Port bug 1241885: Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=jorgk DONTBUILD

Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
(Reporter)

Comment 15

3 months ago

Sorry for the mess, but next time, please let me know in advance.

Target Milestone: --- → Thunderbird 66.0
You need to log in before you can comment on or make changes to this bug.