Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding

RESOLVED FIXED in Firefox 66

Status

()

defect
P5
normal
RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: Gijs, Assigned: ntim)

Tracking

(Blocks 1 bug)

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected, firefox66 fixed)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment)

Reporter

Description

3 years ago
... so that we can remove the draggable toolbar bindings entirely.
Priority: -- → P5
Whiteboard: tpi:+
See Also: → 1500424
Blocks: war-on-xbl
See Also: → 1507863
Assignee

Comment 1

5 months ago
I started looking into this, and it looks like bug 1417847 started adding support for this.
Blocks: 1507863
See Also: 1507863
Assignee

Comment 3

5 months ago
I'm close to having a working patch.
Assignee: nobody → ntim.bugs
Attachment #9032644 - Attachment description: Bug 1241885 - Implement support for -moz-window-dragging in GTK for dragging the window using toolbars. → Bug 1241885 - Implement support for -moz-window-dragging on GTK for dragging the window using toolbars. r=stransky, dao
Attachment #9032644 - Attachment description: Bug 1241885 - Implement support for -moz-window-dragging on GTK for dragging the window using toolbars. r=stransky, dao → Bug 1241885 - Implement support for -moz-window-dragging on GTK for dragging the window using toolbars. r=stransky,dao
Assignee

Updated

5 months ago
Duplicate of this bug: 1507863
Assignee

Updated

5 months ago
Summary: Implement support for -moz-window-dragging in GTK for dragging the window using toolbars → Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding
Attachment #9032644 - Attachment description: Bug 1241885 - Implement support for -moz-window-dragging on GTK for dragging the window using toolbars. r=stransky,dao → Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=stransky,dao
I can review the widget/gtk part if Karl can't do that.
Flags: needinfo?(ntim.bugs)
Assignee

Comment 6

5 months ago
(In reply to Martin Stránský [:stransky] from comment #5)
> I can review the widget/gtk part if Karl can't do that.

Whatever works for you and Karl, I just need a review of the GTK part :)
Flags: needinfo?(ntim.bugs)

IIUC the history here is that toolbar-drag and/or WindowDraggingUtils existed first. -moz-window-dragging was added for https://bugzilla.mozilla.org/show_bug.cgi?id=944836 so that MacOS could perform the dragging without involvement of the app. NT support was added for bug 1163113 for B2G, but not used in real products until https://bugzilla.mozilla.org/show_bug.cgi?id=1219215#c4 . The reasons are not all clear to me, but efficiency of hit testing for frequent NT messages is the reason indicated in https://bugzilla.mozilla.org/show_bug.cgi?id=1107779#c7

I don't know that GTK code can have the same benefits as MacOS and doing hit-testing in the widget code feels a bit awkward to me, but doing things the same way on all platforms seems a good reason to do this.

Assignee

Comment 8

5 months ago

(In reply to Karl Tomlinson (:karlt) from comment #7)

IIUC the history here is that toolbar-drag and/or WindowDraggingUtils existed first. -moz-window-dragging was added for https://bugzilla.mozilla.org/show_bug.cgi?id=944836 so that MacOS could perform the dragging without involvement of the app. NT support was added for bug 1163113 for B2G, but not used in real products until https://bugzilla.mozilla.org/show_bug.cgi?id=1219215#c4 . The reasons are not all clear to me, but efficiency of hit testing for frequent NT messages is the reason indicated in https://bugzilla.mozilla.org/show_bug.cgi?id=1107779#c7

I don't know that GTK code can have the same benefits as MacOS and doing hit-testing in the widget code feels a bit awkward to me, but doing things the same way on all platforms seems a good reason to do this.

In addition to being consistent across platforms, we want to get rid of XBL here too, which is the major benefit of doing this.

Attachment #9032644 - Attachment description: Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=stransky,dao → Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=karlt,bzbarsky,dao
Attachment #9032644 - Attachment description: Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=karlt,bzbarsky,dao → Bug 1241885 - Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=stransky,bzbarsky,dao

Comment 9

4 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/176be7000d33
Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=dao,bzbarsky,stransky

Comment 10

4 months ago
Backout by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0771389994bb
Backed out 1 changesets for build bustages on a CLOSED TREE
Assignee

Updated

4 months ago
Flags: needinfo?(ntim.bugs)

Comment 12

4 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5433228bc018
Implement support for -moz-window-dragging in GTK and remove toolkit toolbar-drag binding. r=dao,bzbarsky,stransky
Blocks: 1521213

Comment 13

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Depends on: 1521630
You need to log in before you can comment on or make changes to this bug.