Closed Bug 1522161 Opened 4 years ago Closed 4 years ago

Limit the number of times a website can go fullscreen/request installing an addon/request subscribing to push notifications

Categories

(Core :: General, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1520589
Tracking Status
firefox66 --- affected

People

(Reporter: marco, Unassigned)

References

()

Details

The website at https://s3.us-east-2.amazonaws.com/rsacbxs/it/index.html is trying to do everything to make you install an addon.
E.g. it goes fullscreen again and again, even after you press ESC.

Could we limit the number of times websites can do these actions?

Thanks for the report!

You'll be glad to hear that resolving some of the underlying issues is on our roadmap for this year.

The bugs in question are bug 1520589, bug 1412561, bug 1522120 and bug 1428913.

Duping to bug 1520589.

No longer blocks: eviltraps
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1520589
You need to log in before you can comment on or make changes to this bug.