Closed Bug 1523703 Opened 10 months ago Closed 10 months ago

Pref on Pocket Newtab experience in Nightly (en locale only)

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.1 - Jan 28 - Feb 10
Tracking Status
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified

People

(Reporter: k88hudson, Assigned: k88hudson)

References

Details

(Keywords: github-merged)

Attachments

(3 files)

In order to get more manual test coverage / early feedback for the new experience, we would like to pref on the Pocket Newtab experience in Nightly. It will continue to be pref'd off in Beta/Release until Firefox 68.

Depends on: 1521084
Depends on: 1524021
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58286693d6d8
Disable discoverystream in test environment r=andreio

Ohhhh. I see what's python complaining about now.

"{\"enabled\": false}".format()

results in

KeyError: '"enabled"'

because it's expecting something like "{0} {1}".format("hello", "world")

So.. we just need to escape the braces.. with the brace.

"{{\"enabled\": false}}".format()

returns

'{"enabled": false}'

Assignee: nobody → khudson
Flags: needinfo?(khudson)
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c31a81865825
Disable discoverystream in test environment r=andreio
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a54dbb34bec5
Disable discoverystream in test environment r=andreio
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b2817234164
Part 2. Set discovery stream pref to [] for tests r=andreio
Blocks: 1526066
Flags: needinfo?(khudson)
See Also: → 1526859
Duplicate of this bug: 1526859

I have verified this issue with the latest Firefox Beta (67.0b9 Build ID - 20190408123043) and with the latest Firefox Nightly (68.0a1 Build ID - 20190410215612) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. I can confirm that the new "Pocket Newtab" experience is on by default on Firefox Nightly and pref'd of on Firefox Beta.

Status: RESOLVED → VERIFIED
Depends on: 1546024
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.