Closed Bug 1532724 Opened 8 months ago Closed 5 months ago

Show inline preferences on add-on details card

Categories

(Toolkit :: Add-ons Manager, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- verified
firefox69 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Depends on 1 open bug)

Details

Attachments

(3 files)

When there's a detail page it should have inline add-on preferences when they are provided by the add-on.

Priority: -- → P2
Blocks: 1545427
No longer blocks: 1525173
Depends on: 1548687
Attachment #9062405 - Attachment description: Bug 1532724 - Inline prefs for HTML about:addons → Bug 1532724 - Part 2: Inline prefs for HTML about:addons
See Also: → 1549450
Attachment #9062405 - Attachment description: Bug 1532724 - Part 2: Inline prefs for HTML about:addons → Bug 1532724 - Inline options browser for HTML about:addons details
Attachment #9062405 - Attachment description: Bug 1532724 - Inline options browser for HTML about:addons details → Bug 1532724 - Part 1: Inline options browser for HTML about:addons details
Assignee: nobody → mstriemer

My feedback as an add-on dev: IMHO it would be best if you could just add a tab "settings" at the top of that new UI.
Currently, the plan is to just add it at the bottom of the "details" tab, is not it? (if I understood it correctly)

The advantage of another tab I see: I personally write very long add-pn descriptions. And currently users have to scroll down a lot just to get to see the options, because these long descriptions are shown before.

The inline options are in a tab, like the permissions.

Duplicate of this bug: 1555809
Blocks: 1555012
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc4d628f9cdb
Part 1: Inline options browser for HTML about:addons details r=rpl,kmag
https://hg.mozilla.org/integration/autoland/rev/3be150246a0b
Part 2: Handle HTML about:addons options page in APIs r=kmag
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Is manual testing required on this bug? If yes, please provide some STR and the proper extension(if required) or set the “qe-verify -“ flag.

Thanks!

Flags: needinfo?(mstriemer)
Attached image Bug1532724.gif

This issue is verified as fixed on Firefox 69.0a1 (20190603101337) under Win 7 64-bit and Mac OS X 10.14.1.

The preference extensions.htmlaboutaddons.inline-options.enabled is set to true by default.

Please see the attached video.

Flags: needinfo?(mstriemer)
Status: RESOLVED → VERIFIED

Comment on attachment 9062405 [details]
Bug 1532724 - Part 1: Inline options browser for HTML about:addons details

Beta/Release Uplift Approval Request

  • User impact if declined: Inline options are missing for extensions in the HTML about:addons
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is behind a pref, verified on Nightly.
  • String changes made/needed:
Attachment #9062405 - Flags: approval-mozilla-beta?
Attachment #9064186 - Flags: approval-mozilla-beta?
Attachment #9064186 - Flags: approval-mozilla-beta?
Attachment #9062405 - Flags: approval-mozilla-beta?

Comment on attachment 9064186 [details]
Bug 1532724 - Part 2: Handle HTML about:addons options page in APIs r?kmag

Beta/Release Uplift Approval Request

  • User impact if declined: Inline options are missing for extensions in the HTML about:addons
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1552184
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is behind a pref, verified on Nightly.
  • String changes made/needed:
Attachment #9064186 - Flags: approval-mozilla-beta?
Attachment #9062405 - Flags: approval-mozilla-beta?
Depends on: 1557509

also opened a minor issue about the new interface with inline options: https://bugzilla.mozilla.org/show_bug.cgi?id=1557509

Comment on attachment 9062405 [details]
Bug 1532724 - Part 1: Inline options browser for HTML about:addons details

support inline options for html about:addons, approved for 68.0b9

Attachment #9062405 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9064186 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue is verified as fixed on Firefox 68.0b9 (20190610153228) under Win 7 64-bit and Mac OS X 10.14.1.

The preference extensions.htmlaboutaddons.inline-options.enabled is set to true by default.

You need to log in before you can comment on or make changes to this bug.