Land Firefox Monitor system add-on into mozilla-central

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
5 months ago
24 days ago

People

(Reporter: nhnt11, Assigned: nhnt11)

Tracking

(Depends on 1 bug, Regressed 1 bug)

67 Branch
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

No description provided.
Attachment #9041707 - Attachment is obsolete: true
Attachment #9041706 - Attachment is obsolete: true
Attachment #9041706 - Attachment is obsolete: false
Attachment #9041707 - Attachment is obsolete: false

(In reply to Nihanth Subramanya [:nhnt11] from comment #3)

Try push link to look at later: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6ee01baf8e198898e31ff566ea45f39c40c5ffd0

Packaging is failing due to the strings.properties files being identical for two en-* locales. I'm currently thinking about what the best way to fix this is.

(In reply to Nihanth Subramanya [:nhnt11] from comment #4)

(In reply to Nihanth Subramanya [:nhnt11] from comment #3)

Try push link to look at later: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6ee01baf8e198898e31ff566ea45f39c40c5ffd0

Packaging is failing due to the strings.properties files being identical for two en-* locales. I'm currently thinking about what the best way to fix this is.

The script that checks for dupes ignores l10n files, but detects them by checking the path for "/locale/" - this addon was using "/locales/". I've changed that and pushed to try again: https://treeherder.mozilla.org/#/jobs?repo=try&revision=db4ee5561e9211c6901702f377de989fb7eed749

Attachment #9041958 - Attachment is obsolete: true
Attachment #9041707 - Attachment is obsolete: true
Attachment #9041706 - Attachment is obsolete: true

Addressed review comments over in the land of Github. Also removed all locales except en-US, since those files will be removed anyway when we migrate translations. Also disabled Telemetry for now till we get data review.

All changes can be viewed in this PR: https://github.com/mozilla/blurts-addon/pull/143

New try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ac448455f1a3418ffe2da6794ff01b24c920d9ef

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/264d828518f2
Land Firefox Monitor system add-on into browser/extensions. r=johannh

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Depends on: 1527635
Depends on: 1531274
Regressions: 1561012
You need to log in before you can comment on or make changes to this bug.