set permission on initial upgrade to incognito feature

VERIFIED FIXED in Firefox 67

Status

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 verified)

Details

Attachments

(7 attachments, 1 obsolete attachment)

Assignee

Description

4 months ago
No description provided.
Assignee

Comment 1

4 months ago

When a user first upgrades to a version where incognito is enabled,
add the permission to all enabled extensions. This preserves user workflow
and addresses other issues (e.g. proxy). This will only happen once.

Assignee

Updated

4 months ago
Group: mozilla-employee-confidential
Assignee

Updated

4 months ago
Group: mozilla-employee-confidential
Assignee

Comment 3

4 months ago
Posted image about:addons banner

Text change on about:addons

Assignee: nobody → mixedpuppy
Attachment #9044034 - Flags: ui-review?(emanuela)
Assignee

Comment 4

4 months ago
Attachment #9044035 - Flags: ui-review?(emanuela)
Assignee

Updated

4 months ago
Priority: -- → P1
Assignee

Comment 5

4 months ago
Posted image post install panel with permission (obsolete) —
Attachment #9044037 - Flags: ui-review?(emanuela)
Assignee

Updated

4 months ago
Attachment #9044034 - Attachment filename: Screen-Shot-2019-02-14-at-5.19.41-PM.png → about:addons banner
Assignee

Updated

4 months ago
Attachment #9044034 - Attachment description: Screen Shot 2019-02-14 at 5.19.41 PM.png → about:addons banner

Comment 6

4 months ago
Comment on attachment 9044037 [details]
post install panel with permission

"Learn More" does not work as a button, unfortunately. It isn't clear what the user will learn more about since it is so far from the "Allow this extension to run in Private Windows" string. We need to be able to incorporate the link/string into the main message. Linking via button won't work.
Attachment #9044037 - Flags: ui-review?(emanuela) → ui-review+

Comment 7

4 months ago
Comment on attachment 9044034 [details]
about:addons banner

Looks good!
Attachment #9044034 - Flags: ui-review?(emanuela) → ui-review+

Comment 8

4 months ago

(In reply to Shane Caraveo (:mixedpuppy) from comment #4)

Created attachment 9044035 [details]
private window first runhttps://bugzilla.mozilla.org/enter_bug.cgi

Looks good!

Comment 9

4 months ago
Comment on attachment 9044034 [details]
about:addons banner

Looks good.

Comment 10

4 months ago

Question: why the message bar is sticky?
Can we unstick it? It's pretty long, and I'm afraid it will annoying to the end users who already act on it. If it's something complicated, I'm ok to track this in a separate bug.

Flags: needinfo?(mixedpuppy)

Updated

4 months ago
Attachment #9044035 - Flags: ui-review?(emanuela) → ui-review+

Comment 11

4 months ago
Comment on attachment 9044037 [details]
post install panel with permission

It looks good. 

If possible, I'll add to the checkbox ~8/16px of margin-top. It needs a bit more air on top.
Assignee

Comment 12

4 months ago

(In reply to emanuela [ux] from comment #10)

Question: why the message bar is sticky?
Can we unstick it? It's pretty long, and I'm afraid it will annoying to the end users who already act on it. If it's something complicated, I'm ok to track this in a separate bug.

I'm not clear what this is about. What message bar?

Flags: needinfo?(mixedpuppy) → needinfo?(emanuela)

Comment 13

4 months ago
Posted video messagebar.mov

The message bar it's the banner in about:addons.

I attached a video that shows what I described in the other comment.

Flags: needinfo?(emanuela)
Assignee

Comment 14

4 months ago

(In reply to emanuela [ux] from comment #13)

Created attachment 9044199 [details]
messagebar.mov

The message bar it's the banner in about:addons.

I attached a video that shows what I described in the other comment.

That is the way that block works. It could change in a followup, it will affect all usage of that block.

Flags: needinfo?(emanuela)

Comment 15

4 months ago

(In reply to Shane Caraveo (:mixedpuppy) from comment #14)

(In reply to emanuela [ux] from comment #13)

Created attachment 9044199 [details]
messagebar.mov

The message bar it's the banner in about:addons.

I attached a video that shows what I described in the other comment.

That is the way that block works. It could change in a followup, it will affect all usage of that block.

I think I never noticed cos the block was never so tall. I'll create a followup bug. This small issue is not a blocker.

Flags: needinfo?(emanuela)
Assignee

Comment 16

4 months ago

more padding on top of checkbox (using margin: 8px 4px 2px;)

Attachment #9044037 - Attachment is obsolete: true
Attachment #9045294 - Flags: ui-review?(emanuela)

Comment 17

4 months ago
Comment on attachment 9045294 [details]
post install panel with permission.png

Good for me! Thank you, Shane
Attachment #9045294 - Flags: ui-review?(emanuela) → ui-review+
Assignee

Updated

4 months ago
Duplicate of this bug: 1529099

Updated

4 months ago
Blocks: 1529347

How does this work with bug 1513344? Do we send privateBrowsingAllowed "on" as soon as the doorhanger value is set (or not set)?

Flags: needinfo?(mixedpuppy)
Flags: needinfo?(lgreco)

Comment 20

4 months ago

(In reply to David Durst [:ddurst] from comment #19)

How does this work with bug 1513344? Do we send privateBrowsingAllowed "on" as soon as the doorhanger value is set (or not set)?

Bug 1513344 doesn't yet cover this, we filed bug 1529347 as the follow up in which we will record an additional telemetry event when a user is enabling an extension on PB windows from the install doorhanger.

Flags: needinfo?(mixedpuppy)
Flags: needinfo?(lgreco)

Comment 22

4 months ago
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3063f37eb7b2
set permission for enabled extensions on initial upgrade r=aswan
https://hg.mozilla.org/integration/autoland/rev/30aad4a580eb
update addon panel text for private windows r=flod,Gijs,mstriemer,rpl

Comment 23

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment 24

4 months ago

(In reply to Cosmin Sabou [:CosminS] from comment #23)

https://hg.mozilla.org/mozilla-central/rev/30aad4a580eb

+<!ENTITY addonPostInstall.incognito.label "Allow this extension to run in Private Windows.">

I’m afraid this is an option, and hence should not end with a trailing period. The same may apply to addonPrivateBrowsing.learnMore.label and private-browsing-learn-more (see legacy-learn-more).

Also see https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Menu_and_control_labels.

(In reply to Ton [:Tonnes] from comment #24)

(In reply to Cosmin Sabou [:CosminS] from comment #23)

https://hg.mozilla.org/mozilla-central/rev/30aad4a580eb

+<!ENTITY addonPostInstall.incognito.label "Allow this extension to run in Private Windows.">

I’m afraid this is an option, and hence should not end with a trailing period. The same may apply to addonPrivateBrowsing.learnMore.label and private-browsing-learn-more (see legacy-learn-more).

Also see https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Localization_content_best_practices#Menu_and_control_labels.

That document shouldn't be used as point of reference for en-US copy. If such a reference can be created, it should live here and be done by the team in charge of copy
https://design.firefox.com/photon/copy/punctuation.html

(In reply to Ton [:Tonnes] from comment #24)

(In reply to Cosmin Sabou [:CosminS] from comment #23)

https://hg.mozilla.org/mozilla-central/rev/30aad4a580eb

+<!ENTITY addonPostInstall.incognito.label "Allow this extension to run in Private Windows.">

I’m afraid this is an option

For clarity, it's a checkbox (and yes, normally they don't have a closing period).

Comment 27

3 months ago
Posted file Bug1527127.zip

This issue is verified as fixed on Firefox 67.0a1 (20190304215035) under Win 7 64-bit and Mac OS X 10.14.1.

After updating Nightly from an older version to the latest one, with some installed extensions, the enabled extensions are automatically granted in PB.

The post install panel is displayed, like in the Comment 17.

Please see the attached video and screenshot.

The banner from about:addons is permanently displayed while scrolling, this issue will be tracked in a separate bug.

Updated

3 months ago
Status: RESOLVED → VERIFIED

Updated

3 months ago
Depends on: 1534131
Assignee

Comment 28

3 months ago

(In reply to Ton [:Tonnes] from comment #24)

The same may apply to addonPrivateBrowsing.learnMore.label and private-browsing-learn-more (see legacy-learn-more).

Given it's a complete sentence, not on an option, I think the period is appropriate. I'll let Flod & Meridel decide.

See attachment 9044034 [details] and attachment 9044035 [details].

Flags: needinfo?(mwalkington)
Flags: needinfo?(francesco.lodolo)

(That's a copy question, not l10n)

Flags: needinfo?(francesco.lodolo)

Comment 30

3 months ago

No period at the end of the link. Following patterns established in other parts of the product, including new Private Windows new tab.

Flags: needinfo?(mwalkington)
Depends on: 1534686
You need to log in before you can comment on or make changes to this bug.