Closed Bug 1528036 Opened 6 months ago Closed Last month

Full page screenshot tool is not functional after page refresh

Categories

(DevTools :: General, defect, P1)

65 Branch
defect

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: jashby2, Assigned: transfusion, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

  1. First enable the screenshot tool in Developer Tools per https://developer.mozilla.org/en-US/docs/Tools/Taking_screenshots.
  2. Navigate to a web page, e.g. https://www.mozilla.org
  3. Open Developer Tools
  4. Click screenshot tool (camera icon in top right of dev tools). Screenshot is successfully saved to Downloads folder.
  5. With Developer Tools still open, refresh the page
  6. Click screenshot tool again...nothing happens. No flash of screen and no screen shot happens.

Actual results:

Per step 6, nothing happens. No flash of screen and no screen shot is saved in Downloads folder.

Expected results:

  • Screen should flash to indicate screenshot was taken
  • Screenshot png should be saved in Downloads folder

FYI, closing and reopening Developer Tools fixes it as a workaround.

Component: Untriaged → Screenshots

Moving to DevTools component. The Screenshots component this was filed in is a different product.

Component: Screenshots → General
Product: Firefox → DevTools

Thanks for filing. I was able to reproduce (on macOS with Firefox beta 66 if that makes any difference).
I'm going to set this as a P1 because this is an important feature that is completely broken, so we should try to find a fix quickly.

When the problem occurs, I can see the following errors in the browser console:

Error while calling actor 'screenshot's method 'capture' can't access dead object

createScreenshotDataURL@resource://devtools/shared/screenshot/capture.js:51:7
captureScreenshot@resource://devtools/shared/screenshot/capture.js:41:10
capture@resource://devtools/server/actors/screenshot.js:26:12
handler@resource://devtools/shared/protocol.js:1206:21
onPacket@resource://devtools/server/main.js:1279:15
receiveMessage@resource://devtools/shared/transport/child-transport.js:66:5
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1

Seems like the ScreenshotActor introduced in bug 1483173 has a this.document property but it does not renew its value when page navigation occurs. I think it should listen to the proper root actor events to do that.

Duplicate of this bug: 1540456
Duplicate of this bug: 1556457

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:transfusion, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(bryan.wyern1)
Pushed by pastithas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5db406983a6
Full page screenshot tool is not functional after page refresh r=yulia,jdescottes
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → bryan.wyern1
You need to log in before you can comment on or make changes to this bug.