[Dedicated Profiles] The "restart" action is not recorded by telemetry

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
4 months ago
18 days ago

People

(Reporter: Ovidiu, Assigned: mossop)

Tracking

(Regressed 1 bug)

Trunk
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 verified)

Details

Attachments

(1 attachment)

Affected versions

  • Nightly 67.0a1

Affected platforms

  • Mac 10.14, Ubuntu 16.04, Windows 10

Steps to reproduce

  1. Open the browser
  2. Go to about:profiles
  3. Select "Restart Normally"
  4. After restart go to about:telemetry and select "Scalars"
  5. Check the "startup.profile_selection_reason" value

Expected result

  • The value is "restart"

Actual result

  • The value is "default"
    The same result is recorded if you close the browser and restarted with the same profile.

Additional notes

  • If from about:profiles you select "Restart with Add-ons Disabled" the issue is no longer reproducible.
Blocks: 1474285
Assignee

Updated

3 months ago
Assignee: nobody → dtownsend
Assignee

Comment 1

3 months ago

So this is a bit weird. Normally when we initiate a restart from within Firefox we set certain flags to ensure that the new instance uses the same profile as previously. It's these flags that I use to set the telemetry accordingly.

The restart buttons in about:profiles however does something different. It doesn't set the flags and so when Firefox restarts it will just go through normal profile selection again, so you can restart and end up using a different profile. That seems odd and not what I would expect from these buttons. I can't see any mention of why this is in bug 1179129. I'd like to propose that we "fix" this bug by just making these buttons do the normal thing and always restart into the same profile. What do you think Romain?

If we decide not to do that then I'd like to know what we should do in telemetry for this case.

Currently restarts of this kind will just generate one of the "firstrun-" or the "default" result. I could change it so for these restarts we get the "restart-" or the "restart" result but I'm not sure that that is correct since this seems like a different case. I can do pretty much whatever here easily, just need to know what is most useful to you Romain.

Flags: needinfo?(rtestard)

(In reply to Dave Townsend [:mossop] (he/him) from comment #1)

So this is a bit weird. Normally when we initiate a restart from within Firefox we set certain flags to ensure that the new instance uses the same profile as previously. It's these flags that I use to set the telemetry accordingly.

The restart buttons in about:profiles however does something different. It doesn't set the flags and so when Firefox restarts it will just go through normal profile selection again, so you can restart and end up using a different profile. That seems odd and not what I would expect from these buttons. I can't see any mention of why this is in bug 1179129. I'd like to propose that we "fix" this bug by just making these buttons do the normal thing and always restart into the same profile. What do you think Romain?

I agree that users would expect here to restart Firefox with the profile they ran when initiating the restart regardless of whether this was default or not.
I could also not find any mention to that on SUMO.

If we decide not to do that then I'd like to know what we should do in telemetry for this case.

Currently restarts of this kind will just generate one of the "firstrun-" or the "default" result. I could change it so for these restarts we get the "restart-" or the "restart" result but I'm not sure that that is correct since this seems like a different case. I can do pretty much whatever here easily, just need to know what is most useful to you Romain.

Let's use "restart" if time allows.

Flags: needinfo?(rtestard)
Assignee

Updated

3 months ago
Blocks: 1533077

Comment 4

3 months ago
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1bc91e8030f2
about:profiles should restart into the same profile rather than allowing profile selection to re-run. r=Gijs

Comment 5

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Depends on: 1533708

This bug seems to be fixed at the moment but, due to bug 1531719, we will leave the status and flags unchecked and wait for bug 1531719 to be investigated so we can re-verify this fix.

Flags: needinfo?(ovidiu.boca)
Assignee

Updated

3 months ago
No longer depends on: 1533708

I verified this on Mac OS X 10.14, Windows 10, Ubuntu 16.04 with FF Nightly 67.0a1(2019-03-10) and I can confirm the fix.

Status: RESOLVED → VERIFIED
Flags: needinfo?(ovidiu.boca)
Duplicate of this bug: 1489857
Duplicate of this bug: 1473203

Updated

18 days ago
Regressions: 1555324
You need to log in before you can comment on or make changes to this bug.