Closed Bug 1528430 Opened 3 years ago Closed 3 years ago

The search performed on a search suggestion result when a one-off button is selected is incorrect

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: adw, Assigned: adw)

References

Details

Attachments

(1 file)

STR:

  1. Type "sw"
  2. Key down to "switch" or any of the non-heuristic suggestion results
  3. Hit enter

You get a search results page for "sw" instead of the search suggestion you chose.

Patch coming up.

Argh, there should have been another step between 2 and 3:

  1. Type "sw"
  2. Key down to "switch" or any of the non-heuristic suggestion results
  3. Alt-down to select a one-off search button
  4. Hit enter

(In reply to Drew Willcoxon :adw from comment #1)

Argh, there should have been another step between 2 and 3:

  1. Type "sw"
  2. Key down to "switch" or any of the non-heuristic suggestion results
  3. Alt-down to select a one-off search button
  4. Hit enter

Good lord, I had no idea both a result and a one-off button could be selected at the same time. This seems both surprising and undiscoverable. Can we drop this feature?

Flags: needinfo?(mak77)

I think it's kind of crazy too, and there's been discussion about it over the years, but it does let you easily search for a suggestion using another engine, if you knew how to do it and actually wanted to do it for some reason. iirc that was one of the original motivations.

It makes more sense though with the heuristic result. e.g., type foo, see that Google is your default but you want to use Wikipedia instead, hit Alt-Down to select Wikipedia, hit enter.

I'm not sure we should worry about changing/breaking the behavior right now for MVP. Or maybe now is exactly the right time, I dunno.

btw bug 1527947 is based on the same behavior.

(In reply to Drew Willcoxon :adw from comment #4)

btw bug 1527947 is based on the same behavior.

That bug seems valid regardless, as you can select a one-off search button and then hover over a search result such that we display the engine name.

Duplicate of this bug: 1528024

I don't have a good answer, because there's no evidence of this being used or unused, we should telemetry it.
The best guess may be to ask Verdi if he thinks this is a meaningful interaction to retain. For now it's really complicate to use because the ALT+DOWN modifier is quite undiscoverable. If we'd (as I hope) switch to TAB to move through groups, then TABbing to search engines may be more discoverable and valuable. But maybe we should only support the click case (you can down to a suggestion and click on a different engine).

Regarding the double selection, there may be ways to drop it regardless of retaining this feature; there is already a bug here, like if I select a suggestion and alt+down we keep the double selection, but if then I move RIGHT, we change engine dropping the selection.
We could just retain the selection on the one-off button, and a down would continue moving through one-off buttons, rather than moving to the next result. The input field text would still be the suggestion text until the selection exits from one-offs.

Flags: needinfo?(mak77)

to clarify the interaction would be:

  1. type "porc"
  2. DOWN to "porcupine" suggestion
  3. ALT+DOWN to a one-off
  4. selection is only on the one-off, text in the input field is "porcupine"
  5. DOWN moves to the next one-off, text in the input field is "porcupine"
  6. The one-offs status text should read as "Search porcupine with:" (currently it's bogus)
  7. after a few DOWN, when the selection cycles back to the heuristic the input field text reverts to the heuristic value

This should pretty much retain the feature without making it confusing, or forcing us to have a double selection.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c052e9f21b8f
When both a suggestion result and a one-off button are selected, search with the suggestion, not what the user typed. r=dao
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.