Closed Bug 1530632 Opened 9 months ago Closed 9 months ago

Info panel - change color for the red Remember this Decision info text

Categories

(Firefox :: Site Identity, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- verified

People

(Reporter: cfogel, Assigned: carolina.jimenez.g, Mentored)

References

Details

(Keywords: regression, Whiteboard: regression)

Attachments

(2 files)

Attached image infoColor.png

Affected versions

  • 65.0.1, 66.0b6, 66.0b11, 67.0a1 (2019-02-25)

Affected platforms

  • Windows 10, macOS 10.13

Steps to reproduce

  1. Launch Firefox, set it to Dark Theme;
  2. Access https://mozilla.github.io/webrtc-landing/gum_test.html
  3. Click on the Screen test;
  4. Click on the Remmember this decision checkbox;

Expected result

  • The string is readable;

*Actual result

  • Color theme setup makes it hard to read;

Regression range

  • for the current regression range, the previous version had the panel's background color set to black ... which wasn't ideal either;
  • First bad: 2018-04-09 17:33:45.385000
  • Last good: 2018-04-09 17:07:57.689000
  • Potential regressor: bug 1451947

Additional notes

  • attached screenshot with the issue;
  • on Ubuntu the color is set to the default one;
Has Regression Range: --- → yes
Has STR: --- → yes
Summary: Info panel, change color for the Remember this Decision red info text → Info panel - change color for the red Remember this Decision info text
Whiteboard: regression

Hey NTim, mind taking a look at this when you got time?
Thanks!

Flags: needinfo?(ntim.bugs)

I feel like there's a dupe for this...

I don't have time to look into this, sorry. Maybe Johann can ?

Flags: needinfo?(ntim.bugs) → needinfo?(jhofmann)

Yes I can, this sounds like a good bug to mentor. We should probably use the same red that we use for the "insecure connection" text in the identity popup (go to http://example.com/ and click the (i) in the location bar).

Finding the colors and source files to modify is left as an exercise (though feel free to ask me if you're stuck).

It will likely involve the Browser Toolbox and Searchfox

Thanks!

Mentor: jhofmann
Component: Theme → Site Identity and Permission Panels
Flags: needinfo?(jhofmann)
Priority: -- → P3

can I work on it?

Assignee: nobody → carolina.jimenez.g
Status: NEW → ASSIGNED

I've given you editbugs access, so you can set your own checkin-needed now :)

where should I do it? I don't see the place to put it...

Flags: needinfo?(jhofmann)

In the whiteboard field (inside the details section), you can type "checkin-needed".

I'll do it, it's in the "keywords" field (not "whiteboard").

Flags: needinfo?(jhofmann)
Keywords: checkin-needed

Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a16d8a7b8a30
Change popup notification warning color (linux, osx and windows) to the one use in .identity-popup-connection-not-secure r=johannh

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Verified with 67.0a1 (2019-03-05).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.