Printing PDFs with CFF fonts is broken on MacOS

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: bdahl, Assigned: bdahl)

Tracking

({regression})

64 Branch
Firefox 67
Desktop
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 wontfix, firefox66 verified, firefox67 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

4 months ago
Assignee

Updated

4 months ago
Blocks: 1489996
Assignee

Updated

4 months ago
Blocks: 1523991
Assignee

Updated

4 months ago
Blocks: 1523667
Assignee

Updated

4 months ago
Blocks: 1524367
Assignee

Updated

4 months ago
Keywords: regression
Assignee

Comment 1

4 months ago

This is more fallout from bug 1489996 and moving the glyphs to the private use area. I have a patch in progress at https://github.com/mozilla/pdf.js/pull/10591

Assignee: nobody → bdahl
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee

Updated

4 months ago
No longer blocks: 1489996
Depends on: 1532355
OS: Unspecified → macOS
Hardware: Unspecified → Desktop
Assignee

Updated

4 months ago
Flags: qe-verify+
Assignee

Comment 2

4 months ago

Fixed by bug Bug 1532355 and bug 1531801.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Assignee

Updated

4 months ago
Attachment #9048569 - Attachment is obsolete: true
Assignee

Comment 5

4 months ago

Comment on attachment 9048576 [details]
Bug 1530881 - Uplift CFF font fixes for MacOS. r=yury

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1489996
  • User impact if declined: PDF's using CFF fonts will not print correctly on MacOS. Again, tax season and would be good to fix sooner rather than later.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: On MacOS:
  1. Load https://instantpot.com/wp-content/uploads/2018/08/12PSI-EPC-Cooking-Time-Tables-English.pdf
  2. Open print dialog
  3. Print to PDF file
  4. Open PDF file in MacOS Preview
    Output should look like displayed PDF not like https://bugzilla.mozilla.org/attachment.cgi?id=9040146
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The path the new code follows is well tested for displaying PDFs. For printing, the fonts are completely broken, so it can't get much worse than that.
  • String changes made/needed:
Attachment #9048576 - Flags: approval-mozilla-beta?
Duplicate of this bug: 1532728

I successfully reproduced the issue on Firefox Nightly 67.0a1 (2019-02-26) under macOS 10.12 using the STR from Comment 5.

The issue is fixed on latest Nightly 67.0a1 (2019-03-06) under macOS 10.12.

I will verify it on beta too as soon as it will be pushed.

Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 67

Comment on attachment 9048576 [details]
Bug 1530881 - Uplift CFF font fixes for MacOS. r=yury

Fix for recent regression, verified in Nightly.
OK for uplift for beta 14.

Attachment #9048576 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee

Updated

4 months ago
Duplicate of this bug: 880181
QA Whiteboard: [qa-triaged]

The issue is fixed on Firefox Beta 66.0b14 (20190307095232), build taken from treeherder. The test was performed on macOS 10.12.

Flags: qe-verify+
Assignee

Updated

4 months ago
Duplicate of this bug: 1529910
Duplicate of this bug: 1523216
You need to log in before you can comment on or make changes to this bug.