Closed Bug 1543720 Opened 2 years ago Closed 9 days ago

Enable the Storage Access API on GeckoView

Categories

(GeckoView :: General, enhancement, P1)

Unspecified
Android
enhancement

Tracking

(geckoview66 wontfix, firefox-esr60 wontfix, firefox66 wontfix, firefox67 wontfix, firefox67.0.1 wontfix, firefox68 wontfix, firefox69 wontfix, firefox70 wontfix, firefox92 fixed)

RESOLVED FIXED
92 Branch
Tracking Status
geckoview66 --- wontfix
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox92 --- fixed

People

(Reporter: ehsan.akhgari, Assigned: aklotz)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [geckoview:m87][geckoview:m88][geckoview:m89][geckoview:m90])

Attachments

(3 files)

Fenix would like to use our cookie restrictions feature (part of Enhanced Tracking Protection). The Storage Access API is part of that feature and we need to enable it on GeckoView.

Blocks: 1469714
Depends on: 1543721
Type: defect → enhancement

Fenix UX issue:
https://github.com/mozilla-mobile/fenix/issues/1749

Vesta says Enhanced TP is not necessary for Fenix MVP.

Whiteboard: [geckoview:fenix:p2] → [geckoview:fenix:my]
Whiteboard: [geckoview:fenix:my] → [geckoview:fenix:m7]
See Also: → 1554071
See Also: 1554071

Deferring this bug from Fenix's M7 (July) milestone to the M8 backlog for later in Q3.

Whiteboard: [geckoview:fenix:m7] → [geckoview:fenix:m8]

Moving to [geckoview:fenix:m9] because Fenix doesn't need the Storage Access API for their ETP MVP.

Whiteboard: [geckoview:fenix:m8] → [geckoview:fenix:m9]
Depends on: 1573236
Depends on: 1573238
Rank: 11
Summary: Enable the storage access API on GeckoView → Enable the Storage Access API on GeckoView
Whiteboard: [geckoview:fenix:m9]

We want to work on this in November.

Whiteboard: [geckoview:m1911]
Whiteboard: [geckoview:m1911]
Assignee: nobody → droeh
Whiteboard: [geckoview:m87]
Priority: P2 → P1
Whiteboard: [geckoview:m87] → [geckoview:m87][geckoview:m88]
Whiteboard: [geckoview:m87][geckoview:m88] → [geckoview:m87][geckoview:m88][geckoview:m89]
Flags: needinfo?(lambeaceh22)
Whiteboard: [geckoview:m87][geckoview:m88][geckoview:m89] → [geckoview:m87][geckoview:m88][geckoview:m89][geckoview:m90?]
Whiteboard: [geckoview:m87][geckoview:m88][geckoview:m89][geckoview:m90?] → [geckoview:m87][geckoview:m88][geckoview:m89][geckoview:m90]
Duplicate of this bug: 1543721
Blocks: 1716091
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a6ec3acd5daf
Add support for Storage Access API in GeckoView. r=aklotz,geckoview-reviewers
Assignee: droeh → aklotz

Looks like the WPT test exceptions weren't updated. I'm running a try push to verify.

Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/53dfbd4776e8
Add support for Storage Access API in GeckoView. r=aklotz,geckoview-reviewers
https://hg.mozilla.org/integration/autoland/rev/71451fcc878a
Remove wpt Android exceptions for storage-access-api; r=jgraham
Status: NEW → RESOLVED
Closed: 9 days ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Flags: needinfo?(lambeaceh22)
You need to log in before you can comment on or make changes to this bug.