Closed Bug 1654832 Opened 2 years ago Closed 3 months ago

[meta] GV Content Permissions overhaul meta

Categories

(GeckoView :: General, task, P3)

All
Android

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: droeh, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: meta, Whiteboard: [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85][geckoview:m87][geckoview:m88])

We've decided that it's better to let Gecko handle persisting content permissions, which requires an overhaul of some of PermissionDelegate, particularly onContentPermissionRequest. We'll be moving away from callbacks in favor of GeckoResults as part of this to bring the API closer to the design of the rest of GV.

See Also: → 1644156
Whiteboard: [geckoview:m81] → [geckoview:m81][geckoview:m82]

Is this something that is on the roadmap and being worked on? This is still blocking our refactoring work - which itself blocks deprecating and removing some outdated components that are used in Focus.

Flags: needinfo?(droeh)

(In reply to Sebastian Kaspari (:sebastian; :pocmo) from comment #1)

Is this something that is on the roadmap and being worked on? This is still blocking our refactoring work - which itself blocks deprecating and removing some outdated components that are used in Focus.

Yup, I'm working on it at the moment. I'll keep you posted, and we can see about uplifting to 81 once it lands if that would help.

Flags: needinfo?(droeh)
Whiteboard: [geckoview:m81][geckoview:m82] → [geckoview:m81][geckoview:m82][geckoview:m83]
Whiteboard: [geckoview:m81][geckoview:m82][geckoview:m83] → [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84]
Whiteboard: [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84] → [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85]
Whiteboard: [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85] → [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85][geckoview:m87]
Whiteboard: [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85][geckoview:m87] → [geckoview:m81][geckoview:m82][geckoview:m83][geckoview:m84][geckoview:m85][geckoview:m87][geckoview:m88]
Depends on: 1697633
Depends on: 1699480
Depends on: 1543720
Keywords: meta
Summary: Overhaul content permissions handling in GV → GV Content Permissions overhaul meta
Priority: P1 → P3
Blocks: 1710447
Depends on: 1711765
Duplicate of this bug: 1640283

The bug assignee didn't login in Bugzilla in the last 7 months.
:fluffyemily, could you have a look please?
For more information, please visit auto_nag documentation.

Assignee: droeh → nobody
Flags: needinfo?(etoop)
Summary: GV Content Permissions overhaul meta → [meta] GV Content Permissions overhaul meta

This landed a while ago and can be closed.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Agi, do you have a link to the bug where it got landed? I would be interested what exactly has been changed. Thanks.

Flags: needinfo?(etoop) → needinfo?(agi)

It's in the dependent bugs :) Before this bug GeckoView would not store permissions and instead delegate them to the app, so it would ask for it every time it was needed. This didn't work well in Gecko where sometimes permissions need to be checked synchronously (and delegating to the app is inherently async) so we moved to a world where GeckoView stores permissions much like Desktop does.

Flags: needinfo?(agi)
You need to log in before you can comment on or make changes to this bug.