Closed Bug 1544418 Opened 4 months ago Closed 4 months ago

Build error on macOS: SDK version "10.14" is unsupported. Please downgrade to version 10.13.

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: kats, Assigned: erahm, NeedInfo)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(2 files)

See bug 1522931 comment 19 onwards. Spinning this out into a new bug so it can be found by mach busted. In summary, currently m-c builds are broken on macOS 10.13 with the 10.14 SDK installed.

We implemented that check because building with the 10.14 SDK results in an unusable firefox (bug 1494022), and it seemed better to yell at people earlier in the build, rather than have them launch firefox and discover that something else is busted. Does your build with the 10.14 SDK not display a black window? Because that would be an interesting datapoint.

I suspect that building on 10.14 with a 10.14 SDK results in the black screen, but building on 10.13 with a 10.14 SDK is ok. I'm fairly sure that's what I was building before. But I'm doing a build now with my m-c rolled back to before bug 1522931 landed to confirm.

Yes, as per https://bugzilla.mozilla.org/show_bug.cgi?id=1522931#c20, I've been building with SDK 10.14 on my macOS 10.13 machine, and my builds run fine (no black window).

It's possible such builds would fail on 10.14, but that isn't an issue for my local development and testing.

Also as noted in https://bugzilla.mozilla.org/show_bug.cgi?id=1522931#c20, I tried the solution recommended by the error message (installing and using the 10.13 SDK), but this led to a compile failure, apparently related to IOKit headers.

And yes, with m-c at rev 43a182c1a3733010b8c95cc8c65ddfe9e0fe0fd6 it builds and runs fine on 10.13 with the 10.14 SDK.

FWIW I'm building w/ 10.14 SDK on macOS 10.14.4 and everything runs fine.

(In reply to Eric Rahm [:erahm] from comment #5)

FWIW I'm building w/ 10.14 SDK on macOS 10.14.4 and everything runs fine.

Does that mean that bug 1494022 is no longer an issue? If not, we could just remove the 10.14 check entirely.

The version check was originally added in bug 1500504, but bug 1522931 extended it to always do the check, not just when --with-macos-sdk was specified in the mozconfig. Maybe the black screen issue was fixed upstream? Or did we fix it and never close the bug?

(In reply to Eric Rahm [:erahm] from comment #5)

FWIW I'm building w/ 10.14 SDK on macOS 10.14.4 and everything runs fine.

I also am building successfully on 10.14.4 with 10.14 SDK. The only problem I've had is fixed by following the steps at https://bugzilla.mozilla.org/show_bug.cgi?id=1487552#c17

:spohl, :mstange - Any objections to bumping the max supported SDK to include 10.14? Asking you two as the reporter for bug 1500504 and assignee of bug 1494022.

Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(mstange)

(In reply to Brad Werth [:bradwerth] from comment #7)

(In reply to Eric Rahm [:erahm] from comment #5)

FWIW I'm building w/ 10.14 SDK on macOS 10.14.4 and everything runs fine.

I also am building successfully on 10.14.4 with 10.14 SDK. The only problem I've had is fixed by following the steps at https://bugzilla.mozilla.org/show_bug.cgi?id=1487552#c17

If you've followed those steps, you are now building with the 10.13 SDK on 10.14.

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)

And yes, with m-c at rev 43a182c1a3733010b8c95cc8c65ddfe9e0fe0fd6 it builds and runs fine on 10.13 with the 10.14 SDK.

This will most likely not force CoreAnimation, which occurs on 10.14 when built with the 10.14 SDK. For anyone switching SDKs for a build, it might make the most sense to switch to 10.11, which is what our build system uses. Any other configuration really isn't tested and results can be unpredictable.

(In reply to Stephen A Pohl [:spohl] from comment #9)

If you've followed those steps, you are now building with the 10.13 SDK on 10.14.

What I meant to convey is that I have been successfully building on 10.14.4 with the 10.14 SDK up until this bug prevented me from doing so. What I am now trying to do is downgrade to the 10.13 SDK as proposed, and see if I can still build successfully.

(In reply to Brad Werth [:bradwerth] from comment #11)

(In reply to Stephen A Pohl [:spohl] from comment #9)

If you've followed those steps, you are now building with the 10.13 SDK on 10.14.

What I meant to convey is that I have been successfully building on 10.14.4 with the 10.14 SDK up until this bug prevented me from doing so. What I am now trying to do is downgrade to the 10.13 SDK as proposed, and see if I can still build successfully.

Build AND run? Or only build? Building always succeeded, but running this type of build used to trigger bug 1494022.

I haven't tried to build and run with the 10.14 SDK in a while and therefore can't say if this check can be removed. Maybe :mstange has done so recently.

Flags: needinfo?(spohl.mozilla.bugs) → needinfo?(bwerth)

(In reply to Stephen A Pohl [:spohl] from comment #12)

Build AND run? Or only build? Building always succeeded, but running this type of build used to trigger bug 1494022.

Yes, build and run on 10.14.4 with 10.14 SDK. No black screen problems (Bug 1494022).

Flags: needinfo?(bwerth)

(In reply to Michael Shal [:mshal] from comment #8)

:spohl, :mstange - Any objections to bumping the max supported SDK to include 10.14?

Note that just bumping the sdk_max_version to 10.14 gave me build errors (on my macOS 10.13 + SDK 10.14 setup). This was surprising to me. The error messages can be seen at https://bugzilla.mozilla.org/show_bug.cgi?id=1522931#c23

(In reply to Brad Werth [:bradwerth] from comment #11)

What I meant to convey is that I have been successfully building on 10.14.4 with the 10.14 SDK up until this bug prevented me from doing so. What I am now trying to do is downgrade to the 10.13 SDK as proposed, and see if I can still build successfully.

Building on 10.14.4 with the 10.13 SDK was successful and my built Nightly appears to be running fine.

See Also: → 1544732
See Also: → 1544763

For me, I was running fine with the 10.14 sdk on 10.14.4 (apart from issues with --enable-warnings-as-errors which I disabled).

I hit the IOKit header issue as mentioned earlier when trying to build with 10.13 (as per the message) - I've filed that as bug 1544763.

Seems to be building fine with the 10.11 sdk so far.

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #14)

(In reply to Michael Shal [:mshal] from comment #8)

:spohl, :mstange - Any objections to bumping the max supported SDK to include 10.14?

Note that just bumping the sdk_max_version to 10.14 gave me build errors (on my macOS 10.13 + SDK 10.14 setup). This was surprising to me. The error messages can be seen at https://bugzilla.mozilla.org/show_bug.cgi?id=1522931#c23

For the record, this happens because prior to bug 1522931 landing, macos_sdk was false (or None or whatever) here and so the -isysroot flag would not get used. This did the The Right Thing on macOS 10.13 + SDK 10.14. With the patch from bug 1522931 plus the sdk_max_version bumped to 10.14, the -isysroot flag DOES get added, and that results in compilation errors.

I don't know what the best fix here is, but if it involves me updating to macOS 10.14 I'm happy to do that, as long as the issues with that configuration are fixed (which it sounds like they are, for some people at least).

I'm hitting this too. I followed the error message's advice, and downloaded the macOS 10.11 SDK from https://github.com/phracker/MacOSX-SDKs, and pointed my .mozconfig at it.

I got past the configure step, but now I'm hitting this:

3:00.97 In file included from /Users/mikeconley/Projects/mozilla-central/intl/icu/source/common/putil.cpp:68:
 3:00.97 In file included from /Users/mikeconley/Projects/mozilla-central/intl/icu/source/common/umutex.h:24:
 3:00.97 In file included from /usr/local/Cellar/llvm/4.0.1/bin/../include/c++/v1/condition_variable:111:
 3:00.97 In file included from /usr/local/Cellar/llvm/4.0.1/bin/../include/c++/v1/__mutex_base:17:
 3:00.97 /usr/local/Cellar/llvm/4.0.1/bin/../include/c++/v1/__threading_support:156:1: error: unknown type name 'mach_port_t'
 3:00.97 mach_port_t __libcpp_thread_get_port();
 3:00.97 ^
 3:00.97 /usr/local/Cellar/llvm/4.0.1/bin/../include/c++/v1/__threading_support:300:1: error: unknown type name 'mach_port_t'
 3:00.97 mach_port_t __libcpp_thread_get_port() {
 3:00.97 ^
 3:00.98 /usr/local/Cellar/llvm/4.0.1/bin/../include/c++/v1/__threading_support:301:12: error: use of undeclared identifier 'pthread_mach_thread_np'
 3:00.98     return pthread_mach_thread_np(pthread_self());
 3:00.98            ^
 3:00.98 3 errors generated.
 3:00.98 make[4]: *** [putil.o] Error 1
 3:00.98 make[3]: *** [config/external/icu/common/target] Error 2
 3:00.98 make[3]: *** Waiting for unfinished jobs....

Which... I don't really know what to do with. Is there a short-term fix I can apply to get my build working again? Maybe manually bumping this?: https://searchfox.org/mozilla-central/source/build/moz.configure/toolchain.configure#139

This is breaking builds for a lot of people, I'm going to suggest backing out part of bug 1522931 and bumping or max version back to 10.14.

Backout update that broke OSX 10.13 builds.

We are no longer seeing black screen issues on OSX 10.14.4.

Pushed by erahm@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9bc9d0c8eccb
Backed out changeset 3d0236f985f8. r=mshal
https://hg.mozilla.org/integration/autoland/rev/32cef42080b1
Increase max OSX SDK version to 10.14. r=mshal
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1544763
You need to log in before you can comment on or make changes to this bug.