Closed Bug 1545175 Opened 8 months ago Closed 8 months ago

Raptor test definitions and taskcluster configs for cold page-load tests on Fenix

Categories

(Testing :: Raptor, enhancement, P1)

Version 3
enhancement

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

(Depends on 2 open bugs)

Details

Attachments

(1 file)

Create the Raptor test INI's and taskcluster configs to run the Raptor cold page-load test suites on Fenix. Will just land this on try and mozilla-central for now.

Since cold page-load takes longer we will restrict each test suite/chunk to 2 subtests/test pages in each.

Set the browser cycles to 15 for cold page-load to match warm page-load page-cycles. Also update the test INI for the existing cold page-load geckoview example test (raptor-tp6m-cold-1), to change browser_cycles to 15 (it is 10 currently which was an oversight) and have 2 subtests only.

Blocks: 1543369
Type: defect → enhancement
Blocks: 1518975
Blocks: 1545186
See Also: → 1532747

2:44 PM <jmaher> rwood: it is intended to run per commit to fenix repo, and on demand on try; running refbrow/fenix on m-c wasn't intended

Thanks :jmaher, correction, Raptor fenix jobs will be try-only.

Depends on: 1532747
See Also: 1532747
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/050964a5e03e
Raptor test definitions and taskcluster configs for cold page-load tests on Fenix; r=Bebe,jmaher
Blocks: 1545730
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1543681
Depends on: 1547491
Depends on: 1547492
You need to log in before you can comment on or make changes to this bug.